Landscape printing doesn't work

Hi,

i just installed Leap (KDE) a few days ago. Trying to print landscape with libre office (5.0.2.2) doesn’t work.
This issue has been a never-ending bug for a few years.
Normally to set the printer language from pdf to postscript solved the problem.
Now it doesn’t. Has anyone a solution?

Thanks!

Might want to say what printer and what driver you use

Brother DCP-7065 DN, rpm packages from the Brother Solution center: generic LPR printer driver and generic CUPS wrapper printer driver.

Maybe the Release Notes to Leap will help:
https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/42.1/#upgrade

Hello Sauerland,

thanks for the link.
If every non-PDF input is converted to PDF now do I have any chance to solve my problem?

Hi!
I have a Brother MFC-7360N (with drivers from solution center) and this is how I solved it in Leap42.1 in Librooffice (i e Calc):
-> Tools meny and choose options
-> choose print in the “left” meny
-> uncheck the “PDF as standard print job format”
-> restart Libreoffice

Viola! Good luck:)

regards

I can confirm this using brother MFC-5890CN
I am using postscript (level from driver)

Hello conram and jonte1,

that is exactly what I have already done. I have installed the generic drivers, I now try to install the non generic.

Hi!

I have no idea if your printer is Network, or local(USB) connected. Remember that I have a different Brother model then you. Did you read what I wrote in your tread about Scanlite?

No I dont change PDF to PS level when printing. I do it ones and directly in Libreoffice. Below is a screenshot of how it looks like in my PC/Yast2/hardware/printers/brother/edit, Networkconnected.

http://jodo.nu/pic/pic4/snapshot30.png

regards

Hi jonte1,

sure I read your comment in my other Skanlite thread.
Now I have installed the non generic drivers and it works!!!
My printer settings are equal to yours.

http://img5.fotos-hochladen.net/uploads/printer14wdcr7b56v.png

Thanks everybody for helping.

Can anyone explain what is the difference in generic and non generic? I understand that generic is available on Brother web. How/where to get non generic?

Thank you

Hello zeppy24,

excuse my late reply. I don’t know exactly the difference too. I just called the other driver on the Brother solution center “non generic”. I don’t want to confuse anyone.
I think a generic driver seems to be something like an universal driver.