LAN works in linux but no longer works in windows

Hello people, I’m sorry to make my first post a plea for help…

I have little knowledge of Linux operating systems, fiddled about with a few distributions. Today I installed openSUSE 11.1 and I love it. It recognised all my hardware and looks great and so on.

However, one problem - I have a TP-Link Router that is connected to Atheros L2 Fast Ethernet… LAN card (it’s not wireless). It works perfectly in Linux, and until now worked just fine in Windows as well (I have dual-boot). Now when I start Windows normally, the computer doesn’t recognize that it has a network connection, even though the router is turned on, connected and the proper drivers are all installed (I tried all possible permutation - reconnecting the cable etc.).

So I’m stuck with my internet/LAN working only in openSUSE and not in Windows XP. The only way to resolve the problem temporarily is to quickly reboot the computer while SUSE is loading and boot the Windows partition but I don’t really want to use this in the long-term.

Any thoughts? :frowning: I’m guessing that it’s probably some option that I haven’t checked. Again I apologise for my lack of knowledge. Thanks.

some people might say that this is not a windows forum but some of us worked with it,and then tried something new and challenging like opensuse(my case). anyway if you do “ipconfig /all” in windows command (dos) are you getting any ip address? is most probably the default one(192.x.x.x) don’t remember it exactly. Try in windows to do “ipconfig /release” and then “ipconfig /renew” which might refresh and get you a good ip address from the router. might be that the router sends the address already to opensuse and when windows gets to be alive cannot get another ip. maybe you can change it in network(opensuse) the start to not be at startup but instead on cable connection and see if it makes a difference for you. Don’t know for sure, try and let us know.

Are you switching to Windows from openSUSE through “Restart Computer” instead of “Shutdown Computer”?

Just shutdown (and completely power off) the computer for few seconds and then start Windows. I am suspecting that Windows may not be loading the firmwire when warm-booting.

SOLUTION: Change from DHCP to static IP’s, and take care that WXP has a different IP than openSUSE.

> So I’m stuck with my internet/LAN working only in openSUSE and not in
> Windows XP. The only way to resolve the problem

this is not a problem, instead it is a great advancement in your
ability to operate safely on the net…



Such strange effects are quite common on dual boot systems, for example some realtek cards’ windows drivers turn off the card on shutdown in an odd way so linux can not turn it on any more.

In this case it seems the other way round, totally powering off the machine might work, but no guarantee there.

Thank you all for your replies. I have tried several of the stuff mentioned but to no avail.

When I try ipconfig in Windows I get a message “Media disconnected” which is simply not true, and when I try the /release or /renew I get a similar message: “The operation failed as no adapter is in the state permissible for this operation.”

I tried both restarting the computer and completely shutting it down, leaving it for a few seconds (also turning off the router), and then back up again, but I again, LAN will only connect in SUSE.

As for static IPs, my ISP charges for that service so I’m not keen on doing that if I could get this solved any other way.

WXP has a different IP than openSUSE

And which would SUSE use? In XP the router is on , is this different in SUSE and could I change it?

YaST2 informs me of the following when I see the overview of my network:

Device Name: eth0
Started automatically at boot
IP address assigned using DHCP

Now I could set it up as Static IP adress but does that change something in my connection with my ISP? Can I even do that if I haven’t previously arranged to have a static IP with them?

Going to try Activate device → On cable connection and see what happens now…

The thing about this whole thing though, a while ago I had Mandriva 2009 on dual-boot and had the same problem, it went away along with Mandriva, but I don’t want to do the same with openSUSE! :slight_smile:

Thanks very much for the replies!

Nope, still won’t recognize the router.

The LED signaling that the computer is connected to LAN lights up only as SUSE is booting.

Something may have gone wrong in Windo$.
It could be the driver itself.
(It is quite common in Windo$ environment that things that work one day may stop working the following day).
Can you try installing the network driver again?

Your router is, netmask
Start Windows, go to the Network Connections, Properties. Everything is set to automatic. Change that to static and enter IP, enter DNS 1 and 2 of your provider, enter Gateway IP That’s all for Windows
Now start openSUSE. Start Yast, Network Devices, Network Settings. Change to static enter IP, netmask, DNS’s and in the Routing Tab, enter the gateway IP

Works on 2 machines in the office, same problem.

Hi kibernick, have you find the solution to fix it? Thanks!