Lan Card Driver Installation

Hi everyone, Im quite new in linux. And Im trying to install Intel EXPI9402PT PRO/1000 PT Dual Port Server Adapter on my machine. I download the drivers for this card from intel web page, but I cant make it work. Im running OpenSuse 11.3 version. When I tried to install it for the first time I got this message:

Makefile:71: *** Kernel header files not in any of the expected locations.
Makefile:72: *** Install the appropriate kernel development package, e.g.
Makefile:73: *** kernel-devel, for building kernel modules and try again. Stop

Then I install the kernel-source package and I got this one:

Makefile:107: *** Linux kernel source not configured - missing version header file. Stop.

I also installed kernel-devel package, but I get the same message. If someone knows something else will be great. Thanks.

Based on the error messages that you have I suggest this:

Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development
[X] Linux Kernel Development
[X] C/C++ Development

Then Press the Accept button on the bottom right and allow these applications to install. See if you can then install the Intel network driver.

Thank You,

Hi thank you for the fast answer, but when I opened Software Management, and selected View button there was no Patterns. The options were:
Technical Data
Package Description
Package Version
File List

And whatever I select nothing happens. I have yast2 by the way, if it`s matter.

It should look something like this

A little different if you use Gnome

I forgot to mention that I work in command-line. This is what I have:

What do you have from a terminal:

zypper lr -d

This is what I get:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
2 | openSUSE_11.3_OSS | openSUSE_11.3_OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
3 | openSUSE_11.3_Updates | openSUSE_11.3_Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
4 | openSUSE_BuildService_-devel:languages:perl | openSUSE_BuildService-_devel:languages:perl | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/languages:/perl/openSUSE_11.3 |
5 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
6 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
7 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
8 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
9 | server:php:extensions_11.3 | server:php:extensions_11.3 | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/php:/extensions/openSUSE_11.3 |

Also install kernel-syms and see if it helps


When logged in as user, become su

type: yast

should look more like:

Hi caf4926, yes this is the screen which I see when I type yast. Then I choose Software Managment, and I see:

Starting the Software Manager
x Initialize the Target System
=> Loading the Configured Repositories

On the bottom I see loading line and after that load the screen which I post above.

Try installing from zypper

zypper in make gcc linux-glibc-devel kernel-source

That should give you enough

Ok there were 15 new packages, all installed successful. But when I make install this is what I get:

Makefile:107: *** Linux kernel source not configured - missing version header file. Stop.

What am I missing?