Linux noob running OpenSuse 11.0. Installed the whole LAMP package via Yast; I selected it as a pattern, clicked install all, etc. as instructed in the documentation/wiki. I’m either completely missing how to get it started, or I did something wrong. I’m familiar with the WAMP package, but I’ve gotten it to run on ubuntu before, and on both I went to http://localhost/. On here, localhost resolves to a failed to connect.

Any help would be appreciated.


You still have to start the services (apache2, mysql). On Debian/Ubuntu installing a server package also automatically enables the service. It’s debatable whether this is the right thing to do, but then that’s how it is with these distros. You can start the services via YaST also. Also going to http://localhost/ will get you Directory index not permitted. Try http://localhost/index.html

There’s more you have to do later. You have to enable php5 in Apache if you hope to view PHP pages.

try to start your server in terminal:

sudo /etc/init.d/apache2 start

PHP is by default started after completing LAMP installation.

Other commands:

sudo /etc/init.d/apache2 stop

sudo /etc/init.d/apache2 restart

Tried that, the following was returned:

greg@linux-2s33:~> sudo /etc/init.d/apache2 start
Module “ruby” is not installed, ignoring.
Check the APACHE_MODULES setting in /etc/sysconfig/apache2.
Starting httpd2 (prefork) /usr/sbin/httpd2-prefork: symbol lookup error: /usr/sbin/httpd2-prefork: undefined symbol: apr_atomic_xchgptr

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf

Also tried via YAST (HTTP Server config) and still doesn’t work (localhost)

Things did show up in htdocs, though.

I didn’t face this module issue before.
Did you install all apache files in LAMP from yast.
check it again there.

Yup, everything in that pattern is installed.

You may still have some missing dependencies, something went wrong. Please do this:

ldd /usr/sbin/httpd2-prefork

and post the result.


greg@linux-2s33:~> ldd /usr/sbin/httpd2-prefork => (0xffffe000) => /lib/ (0xb802b000) => /usr/lib/ (0xb8001000) => /usr/lib/ (0xb7fe8000) => /usr/lib/ (0xb7ec5000) => /lib/ (0xb7e9e000) => /usr/lib/ (0xb7e78000) => /lib/ (0xb7e6e000) => /lib/ (0xb7e38000) => /lib/ (0xb7e20000) => /lib/ (0xb7e1c000) => /lib/ (0xb7cd9000)
/lib/ (0xb8063000) => /usr/lib/ (0xb7c9a000) => /usr/lib/ (0xb7c8a000) => /lib/ (0xb7c77000) => /usr/lib/ (0xb7c5e000) => /usr/lib/ (0xb7c19000) => /usr/lib/ (0xb7ad5000) => /lib/ (0xb7ac0000)

Strange. contains one or two apr_atomic_xchg* symbols but not apr_atomic_xchgptr. Could you have a foreign apache module installed from somewhere else, from an external package for Ruby perhaps? Do you have any non-OpenSUSE packages or software installed? Or perhaps a hangover from an older version of SUSE?

Hah, ok, a search found the solution. You need to update some additional packages after the update to apache2, which I assume is because you got the latest version during the install.

Starting httpd2 (prefork) /usr/sbin/httpd2-prefork: symbol lookup error: /usr/sbin/httpd2-prefork: undefined symbol: apr_atomic_xchgptr | SUSE & openSUSE

Thanks, that did the trick.