La lutte continue...

Apologies to all non-French speakers, but my struggles with openSuse 11.0 installation continue. I installed it onto a standard PC with a 1 TB hard drive with a single partition containing Microsoft Windows XP Professional. I accepted the default partitioning the install recommended and created a single user named barney. The install seemed to go fine but when I came to use the system at random intervals my keyboard suddenly died. I know there is not a physical fault with the keyboard as it works fine when I log in as root. It is connected to the PC through a KVM switch and also works fine on 2 other PCs running Windows NT4 and 98 on these other machines connected to the same KVM switch. I have to maintain some legacy Windows applications on these machines, but otherwise am trying to switch totally to Linux for reasons of speed, security and stability.

Rebooting as user barney after keyboard death did not revive it. The only practically useful advice I was given on these forums was to log in as root and create a new user. So barney1 was created and for a couple of days this worked fine until random interval keyboard death. Next barney2 was created and now I am up to barney6 after barney5 lasted a whole two weeks! In all this time I have only been using Firefox for Internet browsing, Okular for pdf viewing, and OpenOffice for new file and presentation creation. I have never tried to edit any of the configuration files.

The other advice here has been to check my xorg.config file, whose contents I have posted leading to conflicting opinions as to whether or not it needs editing. As a relative newcomer to Linux, I am trying to learn how to use it productively. I live in Buckinghamshire, UK, about 25 miles NW of London. My local Linux Users Group has a website that has not been modified since 2005 and does not seem to hold meetings any more.

Can anyone suggest how I could persuade an openSuse 11.0 guru to look at my system in person so that I could get a stable installation up and running? Otherwise who knows, I may have to return to the Windoze fold…:frowning:

My e-mail address is <>.

When your keyboard input dies… can you regain keyboard control by plugging in a usb keyboard directly?
Also does the key combination <ALT><CTRL>+<F1> bring you to the first terminal session? Or when hitting Caps Lock, does the light on the keyboard still react? (Just to see if it’s total keyboard loss or just within the X session).

dmesg is a console command that can give you a good clue why hardware is failing.

One thing that would be good to know is which DE you are using… KDE 3-4, GNOME or other? It could well be you only need to remove some specific configuration files to get back into business with the first account.

Lets give these a start? :slight_smile:


p.s. What’s the apologies to all non-French speakers about? This in an English speak… typing forum. :wink:

  1. I cannot plug in a USB keyboard as I only have PS2 ones.

  2. Ctrl+Alt+F1 does absolutely nothing.

  3. Caps Lock light is off by default at boot and pressing it repeatedly does nothing to change that.

  4. I am using KDE 4.0.4 “release 15.1” - the default that came with the openSuse 11.0 DVD.

  5. I cannot issue the dmesg command in a console window as the keyboard is dead!

  6. The reference to French speakers was in the subject line…but then I did visit Paris as an observer in 1968.

Lol (to point 6), & got it!

Ok, well the keyboard input is definitely gone then.

To test you could try taking the KVM switch out of play.

As for 4.0.4, there is enough posted (being a development release) on that & it could well be that is the source of the problem.

As a first step/suggestion: try upgrading to KDE 4.1 (more info on that here : KDE/KDE4 - openSUSE) or better yet install KDE3 or GNOME to make sure it’s not an issue in combo with KDE 4.x,
To install KDE3 or GNOME fire up YaST > Software Management - select to view the patterns and add the GNOME or KDE3 Desktop environment. The needed dependencies will get added.

You choose which DE you want to use in the session section of your login screen.

If keyboard lockup’s stop you have your answer.

Btw. You have applied all other available updates? giving you kernel 2.6.25-16 amongst others?