Kwin windows shortcuts

Hey guys, I’m a noob linux user, and I’m using KDE3.5 with kwin. One of the features that I absolutely love is that you can set windows shortcuts. Now, the problem I’ve run into is that the shortcuts are not permanent for certain applications but are for others. I have gone into advanced windows settings and set the shortcut there (forced) to what I want, but to no avail. Anybody have a solution for this? Like, is there a config file or something that keeps this stuff that I can manually edit to save? This would make my windows managing much more efficient.

Thanks in advance,

Also, in the same vein, I try to separate my workspaces by application, and it seems like some applications (konqueror especially, does everything I want it to through this lol) listen to the “force” to one desktop, while others (openoffice writer for example) do not at all. Any way to remedy this?


Sorry about the bump + triple post, but does anyone experience the same problem? Some other things that Kwin doesn’t appear to handle correctly are: Kommando’s shortcut (I initially set it to alt+F1 and clicked “reassign” to steal it from KMenu’s shortcut, but for a while alt+f1 still opened kmenu, even after I removed it from panel. Even after it stopped opening KMenu, it wouldn’t open Kommando.

I must say, you’re not very clear in what you want to achieve. AFAICS you want programs to appear on the same virtual desktop all the time. I have that working in KDE4. Works with OO.o , in fact with any app.
There might be something going on that I met yesterday: a 11.0 install running KDE3 but with a total mixture of KDE3 and KDE4 programs. The KDE4 ones would not listen to settings mentioned in KDE3 and the other way round. My customer decided she wanted 11.1 and the latest KDE4 (installed from Reloaded-Live-CD). Did a fresh install and now it works like a charm, incl. the advanced settings to bind programs to one specific virtual desktop