kwin_wayland segfault on start

Hi there,
After >10 years I tried Wayland another time. It never worked for me in the past and this time it failed as well.
I have prop. nvidia driver installed and when I try to log into a wayland session the programm crashes as seen in the log.
BTW: Wayland is not crashing in VMWare, but there is a discrepancy of cursor and cursor position in Apps. E.g. in “vs code” I can’t select a words.
Is Wayland still unusable? Is there a way to find the issue of the crash?

Feb 12 09:51:53 linux-li4o sddm[2169]: Reading from "/usr/share/**wayland**-sessions/plasma**wayland**.desktop" 
Feb 12 09:51:53 linux-li4o sddm[2169]: Reading from "/usr/share/**wayland**-sessions/plasma**wayland**.desktop" 
Feb 12 09:51:53 linux-li4o sddm[2169]: Session "/usr/share/**wayland**-sessions/plasma**wayland**.desktop" selected, command: "/usr/lib64/libexec/plasma-dbus-run-session-if-needed /usr/bin/startplasma-**wayland**" 
Feb 12 09:51:53 linux-li4o sddm-helper[13631]: Starting: "/usr/share/sddm/scripts/**wayland**-session /usr/lib64/libexec/plasma-dbus-run-session-if-needed /usr/bin/startplasma-**wayland**" 
Feb 12 09:51:54 linux-li4o dbus-daemon[938]: [system] Activating via systemd: service name='org.freedesktop.locale1' unit='dbus-org.freedesktop.locale1.service' requested by ':1.307' (uid=1000 pid=13634 co
mm="/usr/bin/startplasma-**wayland** ") 
Feb 12 09:51:54 linux-li4o dbus-daemon[2207]: [session uid=1000 pid=2207] Activating service name='org.kde.KSplash' requested by ':1.132' (uid=1000 pid=13634 comm="/usr/bin/startplasma-**wayland** ") 
Feb 12 09:51:54 linux-li4o kernel: kwin_**wayland**[13676]: segfault at 8 ip 00007f3ea15de036 sp 00007ffc73addb20 error 4 in[7f3ea15af000+32000] 
Feb 12 09:51:55 linux-li4o kernel: kwin_**wayland**[13728]: segfault at 8 ip 00007ff311965036 sp 00007ffdb41cb080 error 4 in[7ff311936000+32000] 
Feb 12 09:51:55 linux-li4o kernel: kwin_**wayland**[13766]: segfault at 8 ip 00007f804a1b7036 sp 00007fff39847840 error 4 in[7f804a188000+32000] 
Feb 12 09:51:55 linux-li4o kernel: kwin_**wayland**[13804]: segfault at 8 ip 00007f4de648d036 sp 00007fff101891e0 error 4 in[7f4de645e000+32000] 
Feb 12 09:51:56 linux-li4o kernel: kwin_**wayland**[13842]: segfault at 8 ip 00007f85c25db036 sp 00007ffecc648f60 error 4 in[7f85c25ac000+32000] 
Feb 12 09:51:56 linux-li4o kernel: kwin_**wayland**[13880]: segfault at 8 ip 00007f7ae196a036 sp 00007ffef1cb8c20 error 4 in[7f7ae193b000+32000] 
Feb 12 09:51:57 linux-li4o kernel: kwin_**wayland**[13918]: segfault at 8 ip 00007ff5624cf036 sp 00007ffce3ff3ce0 error 4 in[7ff5624a0000+32000] 
Feb 12 09:51:57 linux-li4o kernel: kwin_**wayland**[13956]: segfault at 8 ip 00007f6adca2c036 sp 00007fff51977c40 error 4 in[7f6adc9fd000+32000] 
Feb 12 09:51:57 linux-li4o kernel: kwin_**wayland**[13994]: segfault at 8 ip 00007fa5e29d1036 sp 00007ffd95938640 error 4 in[7fa5e29a2000+32000] 
Feb 12 09:51:58 linux-li4o kernel: kwin_**wayland**[14032]: segfault at 8 ip 00007f482124f036 sp 00007fff82cb52f0 error 4 in[7f4821220000+32000] 
Feb 12 09:51:58 linux-li4o klauncher[13687]: qt.qpa.**wayland**: Creating a fake screen in order for Qt not to crash 
Feb 12 09:52:01 linux-li4o sddm-greeter[14124]: Reading from "/usr/share/**wayland**-sessions/plasma**wayland**.desktop"

I updated the nvidia driver. Now it does not crash anymore, but there are other issues and it crashed later in the session.
Is the nouveau driver working? Are there artifacts like flickering? Does it crash as well?