KWin refuses to enable desktop effects

suse 11.4 tumbleweed, kde 4.6.5, on laptop dell latitude E6510, with intel i7, 4Mb ram, NVIDIA 3100
Yesterday all effects was working well, no update and no changes, and today I dont know why but plasma crashed at startup, after a couple of try I login on gnome and renamed /home/.kde4 folder, now kde starts but when I try to enable some effects, cube, wabbling windows and others, kwin message appear sayng that effects cannot be enabled.
suggestions???
thnx :slight_smile: pla

There is a Tumbleweed subforum here. Why didn’t you post there? More change that fellow Tumbleweed users read it.

No updates? I had a lot of them this morning, amongst which…a new kernel. That would break the NVIDIA driver. When running Tumbleweed and running into graphics problems, first check this. Can you post the output of

uname

-a ? And run

glxinfo | grep direct

and post the output as well.

No updates from now (not working situation) and previous (working situation), I’m running tumbleweed but disabled automatic updates and tabooed kernel, when I have time to risk I use SAKC :-))

here is:

pla@linux-y7c9:~> glxinfo | grep direct
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 138 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x6800002
Serial number of failed request: 31
Current serial number in output stream: 31
pla@linux-y7c9:~> uname -a
Linux linux-y7c9.site 2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 x86_64 x86_64 x86_64 GNU/Linux

thnx pla:-)