KWIN Failure with 12.3 Upgrade Installation

Hi all!
I got the fever and went to upgrade my primary box from 12.2 to 12.3 this morning.
I grabbed the KDE Live first to check drivers etc and all was sweet (nouveau video), so off the Full Install disk I ran an Upgrade of existing system.

All appears to have installed fine, except I can’t launch KDE Plasma -it gets to about the third section of the splash and hangs. I’ve done a little testing which leads me to think KWIN is not working right;

  • Created a new user with same outcome as my existing
  • Can start a RazorQT session using Openbox with no problem - everything works
  • RazorQT with KWIN hangs straight away.

From these I conclude it’s nothing in the user profile, and as Razor is happy with Openbox I think KWIN is the culprit.

Any suggestions on logs to examine next?

Thanks, Alex

You can try editing “$HOME/.kde4/share/config/kwinrc”. Look for a section “[Compositing]” and if there is a line with “Enabled=” set that to false. If there is no line, then add “Enabled=false” as a line in that section.

That turns off desktop effects, which might be causing your problems.

Thanks for the speedy reply!

Turning off desktop effects did give me a different failure: fragments of the splash animation showed in corrupted blocks at top right of the screen, and did get as far as showing part of the Crash handler dialog saying the the plasma shell (I think) had died.

I think I’ll just run a full reinstall :frowning:


You may need to install the nvidia drivers.

Fortunately, my older box with nvidia graphics works well enough with nouveau. So I put up with its limitations and avoid the proprietary driver. However, many people find that nouveau does not work even minimally for their graphic card. Check the opensuse wiki.

With 12.2 everything was very happy with the nouveau drivers, which for some reason worked better for me than the proprietary Nvidia ones (including WebGL in Firefox and Chromium)

Goes to show that a million things change in a few months, and switching to the latest Nvidia drivers has that KDE 4.10 goodness oozing out of every corner: somehow though WebGL is OK in Firefox but not Chromium.

For me, nouveau was pretty broken in 12.2, though I stuck with it. The Gnome screen was unreadable, due to all of the tearing, unless I forced fallback mode. (I prefer KDE anyway).

With 12.3, nouveau is a lot better. Gnome 3 is actually usable. Things are not perfect – the mouse cursor sometimes disappears – but a lot better.

On a still older system with ATI radeon graphics, things are worse with 12.3 than with 12.2.

I guess they made a lot of graphics changes – some for the better and some for the worse.