KWIN broken after latest Nvdia driver update

Hi all

I received an update to the G04 Nvidia driver today to version 390.25_k4.4.76_1-4.1. After reboot KDE graphics seem to be broken - partial windows appear, duplicated, across the screen and apps won’t load. I also repeadtedly get a KWIN message saying “Desktop effects were restarted due to a graphics reset”.

I got KDE graphics working again by choosing the failsafe option at login, and I think the best thing for now would be to roll back to the previous Nvidia driver. However YAST doesn’t seem to give me this option - the only driver version listed is the latest one.

Can anyone suggest a course of action so I don’t have to choose failsafe at each login?

Regards

Fred

I cant even get the failsafe to work. All I get is a blank screen. Fortunately, I have an oldish installation that I use as my own ‘failsafe’. Do you have to supply any extra parameters at boot time? Michael Railtton

I may not have been clear enough when I used the term “failsafe”. Just to clarify, I’m not taking about the failsafe kernel option at boot - I allowed the latest kernel version to be used. But I use multiple user accounts in KDE so after boot I’m presented with a (green) logon screen for the window-based environment where I can choose either account. (I’m not sure what this looks like, or whether it appears, if only one account is used.)
However at the bottom left of that logon screen there is a settings icon, and it’s using that icon that allows me to choose failsafe for the windows session.

Depending on what card you use, you may try to uninstall the G04 driver and install G03 instead.

You’re not the only ones having problems with 390.25…
http://bugzilla.opensuse.org/show_bug.cgi?id=1080742

Thanks wolfi, useful to know there’s a logged issue with this version.
I don’t think I’ll mess about with other versions right now, as the graphic environment is working perfectly as long as I enter it in its failsafe mode.

This does make me wonder though what the graphics failsafe mode actually does. Presumably it’s switching off some features - there must be a clue there as to what’s going wrong.

Yes, mainly usage of hardware acceleration/OpenGL I think.

Btw, there’s also http://bugzilla.opensuse.org/show_bug.cgi?id=1080787 now.
This suggests the problem is specific to the rpm packages and the .run installer (i.e. installing “the hard way”) should work fine.

Thanks for the info that there is a known bug in 390.25. I cannot boot in either normal or recovery mode - just a blank black screen.
I hope that when the bug is resolved we’ll learn how to update to working driver.
I have booted with a pre-update NVIDIA driver from a snapper snapshot but I keep getting messages about configuration files being missing.
I have forgotten how to force a boot to a given snapshot (i.e. make the snapshot the ‘current’ version).

Yes, because nvidia’s OpenGL libraries only work with the nvidia driver.
IOW, just having nvidia installed, breaks OpenGL support for every other driver, in particular the fallback driver that’s used by recovery mode.

Uninstall the package nvidia-glG04 (or better all nvidia packages) to “fix” that.

I hope that when the bug is resolved we’ll learn how to update to working driver.

zypper up

(unless you uninstalled it of course)

I have forgotten how to force a boot to a given snapshot (i.e. make the snapshot the ‘current’ version).

Boot the snapshot and run

snapper rollback

Also affected by this bug. Normal KDE update. Now PC boots to blank screen with only mouse pointer visible. Adding my name to the list because nothing gets fixed unless people complain.

I need instructions on how to downgrade to previously working Nvidia driver using the command line.

Complaining here in these user forums doesn’t likely get anything fixed either though.

You cannot, older versions are not available in the repo anymore.

As I wrote you could switch to the G03 version, if it supports your card.
Run YaST, uninstall all nvidia packages and install x11-video-nvidiaG03 instead.

Or, if you use the default btrfs as root filesystem, you can boot a previous snapshot and rollback.

What does this mean:

API mismatch: the client has the version 390.25, but this kernel module has the version 384.111

Impossible. PC boots to blank screen with only mouse pointer visible.

This means that the kernel module is still the old version (384.111) and doesn’t match the installed nvidia driver version (390.25). That cannot work.

Has it been updated?

rpm -q nvidia-gfxG04-kmp-default

Press Ctrl+Alt+F1 to switch to text mode, or boot to text mode in the first place by adding ‘3’ to the boot options.

Your question was how to downgrade the driver using the command line, so I assumed you know how to get to text mode…

Alternatively, press Ctrl+Alt+Backspace twice to get to the login screen and then choose IceWM instead. That should work even with a broken nvidia installation.
Although, if you are using SDDM as login manager, that won’t work either.

Output:
nvidia-gfxG04-kmp-default-390.25_k4.4.76_1-4.1.x86_64

Ok, try to re-install it:

sudo zypper in -f nvidia-gfxG04-kmp-default

If that doesn’t help, please post the list of installed kernel packages:

rpm -qa kernel*

Problem appears to have been resolved by using zypper to remove and then reinstall x11-video-nvidiaG04

Ok, many thanks wolfi. I did the rollback and now all is fine. I have now locked down to Nvidia drivers in YAST so that they don’t update.

I too can confirm that, a simple zypper reinstall of the G04 driver (per post #17) fixes the problem for me. Thanks again wolfi.