KVM switch and proper resolution


I’m running a BenQ T221WA monitor through a LevelOne 0201 KVM switch which cause problems in OpenSUSE. It appears the switch has problems passing through the DDC signals (or whatever it is used for signaling between the monitor and the computer). If the KVM switch is used, I’m stuck with a 1600 x 1200 resolution but what I want is the native 1680 x 1050 resolution. If I connect the monitor directly, OpenSUSE correctly identifies the monitor and sets the proper resolution and reconnecting the KVM switch without turning off the computer works splendidly and the proper resolution is set. However, as soon as I restart the computer, it once again resumes the 1600 x 1200 resolution…

Is there anyway to keep OpenSUSE from changing the display settings once they have been correctly set? I don’t want it to try to identify the monitor since obviously it goes wrong every time. If I ever get another monitor, I’ll deal with setting it up then. For now I just want to save and keep the proper settings.

My graphics card is an ATI Radeon HD 4830 with the fglrx drivers.

I had the same problem in Windows 7, but there it was enough to manually install the drivers for the BenQ monitor, and since then it doesn’t try to re-detect the display. I would like the same solution for OpenSUSE, if possible.

Thankful for any help!

Where/how are you setting the resoluton?
I found the best place to set it is in runlevel 3 using sax2. You can then run the ati-catalyst to check the resolution is correct.
It should autodetect the monitor. If it doesn’t, try running sax2 and setting up with the monitor conncted directly to the pc and then reconnect to the kvm.
My hp/compaq kvm is rated at 800x600 but will allow me to set higher resolutions, although some kvm’s don’t like a higher resolution than their rating.

Thanks for the reply!

I didn’t set any resolution explicitly. When directly connected, the resolution was automatically detected as the correct 1680 x 1050. However, plugging in the KVM switch made the resolution revert to 1600 x 1200 (VESA) and I can’t change it in sax2 (the resolution in the properties box already says 1680 x 1050 but it’s obviously not correct.) If I look at the xorg.conf, to my eyes it also appears correct, but the resolution on my monitor is clearly 1600 x 1200 (4:3).

I tried your suggestion of going init 3 and running sax2 but that one just wanted to set 800 x 600 resolution and it wasn’t possible to change it other than the usual 1600 x 1200…


How would I set resolution using aticonfig? Just running aticonfig with the --resolution parameter?

This is also not a case of running the KVM switch out of specs. It says it supports up to 1920 x 1440, so 1680 x 1050 is within tolerances. Like I said, it works great in Windows 7 after some manual tweaking of installing drivers (the monitor was detected as a generic plug-and-play but manually installing the BenQ driver seemed to fix everything.) I also tried Mac OS X and that was the most pleasant experience since it correctly deduced everything about the monitor despite going through the KVM switch, and both vendor and model number was correctly detected as well as the proper native resolution. I don’t know how it did that (magic?) but it obviously works.

But I’m sure it can be made to work in OpenSUSE as well. It just seems it’s not quite smart enough automatically detect the proper settings, but it also not dumb enough to just keep the working settings. I would be completely satisfied if I could just force it to retain the settings is uses when the monitor is directly connected. I’m only going to be using this one monitor for the foreseeable future so auto-detecting monitor changes is just counter-productive in this case…

So when setting up without the kvm, all is fine, but the problem arises when you plug in the kvm.
When you go to runlevel 3, try first:
/usr/bin/aticonfig --initial
and then run
sax2 -r -m 0=fglrx

With my display and kvm, I had to set it to a vesa monitor at the correct resolution. Start first using the lowest sync settings, in case the kvm doesn’t like it.
Once configured, stay as root and check the xserver works first by using startx.
No tweak the settings using the catalyst control centre (should be in the programs in the programs menu, otherwise search for it.)
Once all is fine (!?) logout and either reboot or type init 5 to get back to run level 5.
I had quite a few problems with my radeon card and kvm.

Yep, I did the aticonfig --initial and sax2 -r -m 0=fglrx as part of the fglrx driver installation. It only works fine without the KVM connected…

Trying to use the Catalyst control centre will only let me select 1600 x 1200 with KVM connected. When I tried directly connected the monitor, and did an autodetect in CCC, it did recognize the monitor, but for some reason the max resolution was set to 1440 x 900?!