KVM Qemu Mouse Pointer

Hi All
I have installed a OpenSuse Leap 15 (KDE desktop enviroment) as guest on opensuse 42.1 host notebook with kvm as Hypervisor.
After the clean installation, (the first boot) the mouse work until login screen… after login the mouse pointer disappear and the mouse not work, i can interact only with keyboard.

I have tried:

  • run the update suggest and reboot (KO)
  • Reinstall the guest machine (KO)
  • Reinstall the guest machine with gnome (hang to leap logo after installation then the first boot) so i can’t verify the mouse functions
  • Go in init level 3 and try the basic cut and past command with mouse curson (KO)
  • The mouse kernel module (is bulit-in in the kernel) so i can’t reloaded

Thanks for attention

Kind regards


Sometimes the virtual machine “captures” the mouse.

While at the virtual machine, try CTRL-ALT to release the mouse.

Hi **nrickert
**Thanks for the answer](https://forums.opensuse.org/member.php/49759-nrickert)
The problem is on the guest, openSUSE Leap 15, where the mouse pointer not appear and works only the keyboard, in fact when i press CTRL - ALT the mouse pointer appear but it’s on the host, openSUSE Leap 42.1 where it works as usual.


Okay. I misunderstood the problem.

Where are you running KVM?

Which desktop are you using for your guest VM?

I am not having that problem here. For comparison, I’m running KVM under Leap 15.0. I previously ran it under Leap 42.3, and also did not have a problem. And I usually run Plasma 5, sometimes as a Wayland session and sometimes as an X session. I also just tested with Gnome, both X and Wayland, and did not see any similar problem.

Hello nrickert

KVM (/usr/bin/qemu-system-x86_64 --version
QEMU emulator version 2.3.1, Copyright (c) 2003-2008 Fabrice Bellard
run on openSUSE Leap 42.1, the host (physical asus notebook).

openSUSE Leap 15 (Guest VM) has the KDE environment Plasma

In the login screen the mouse works, after the login, sound, network keyboard works but mouse not.

I would install the guest VM because i need to test many software and after positive outcome, i will install openSUSE Leap 15 on 2 different hardware (server and laptop)

Let me know if you need more detail informations
Thanks again


I would wonder whether your problem is using a 42.1 host. Maybe you are seeing a bug that has been fixed in later versions.

…it’s possbile. But Leap 15 has few days.

Possibly you need to add a tablet to the guest VM?


I have tried your suggestion, but nothing.
I have installed opensuse LEAP 42.3 as guest VM, on same host and the mouse poiter works without problems.

For now, the only difference noticed is in the output of dmesg.

On guest VM 42.3 there is one more line in bold

dmesg | grep -i mouse
mousedev: PS/2 mouse device common for all mice
**input: ImExPS/2 Generic Explorer Mouse as /device/platform/i8042/serio1/input/inut2

**On Guest opensuse LEAP 15 missing…


Here’s what I am seeing with a Leap 15.0 guest:

% dmesg | grep -i mouse
    1.453111] mousedev: PS/2 mouse device common for all mice
    2.514175] input: ImExPS/2 Generic Explorer Mouse as /devices/platform/i8042/serio1/input/input2
    3.597952] hid-generic 0003:0627:0001.0001: input,hidraw0: USB HID v0.01 Mouse [QEMU QEMU USB Tablet] on usb-0000:00:05.7-1/input0

That’s with Leap 15.0 also as the KVM host.

My mouse is actually a USB mouse. So that tells me that the guest machine is seeing a virtualized mouse (that’s not surprising). It suggests to me that your KVM host is not properly communicating with the Leap 15.0 guest. And I think that points to the problem that your 42.1 is well beyond its supported life. There have probably been some changes since 42.1 that Leap 15.0 as guest depends on.

With Destkop Session IceWM Session, TWM, the mouse WORKS.

Plasma and Plasma Wayland not

p.s. i have previous removed Tablet device.


I suggest you file a bug report.

openSUSE:Submitting bug reports

Include a link to this forum thread in your report.