KVM Networking guest not working

Following configuration:

host server opensuse 11.4_x64 running KVM (whatever version comes on the
11.4 DVD)

guest server opensuse 11.4_x64

host networking is working.
guest does not

Bridge networking was selected at install time.
IP information and DNS triple checked.
Guest and Host Firewalls are disabled.
IPv6 disabled on guest and host.

Any ideas?


For some reason the bridge was not created.

‘brctl show’ has no contents.

Hash: SHA1

Until I started the libvirtd service I didn’t have one either. Possibly

sudo /etc/init.d/libvirtd start

Good luck.

Want to yell at me in person?
Come to BrainShare 2011 in October: http://tinyurl.com/brainshare2011
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Unfortunately no. libvirtd is running. I had to manually enable it to even
open the GUI apps. I created a bridge using YaST but it is not bound to
eth0. The YaST GUI provides no means for connecting it. I’m at a loss.
Clicking on the Help button gives a blank window. Nice.
VMware handled all of this backend business…Get what you pay for I guess.
There are a hundred tutorials online and they all differ. Most involve heavy
mucking in the shell which I have learned in the past is a good way to get
your config overwritten later.

I wrote a script to create/delete bridges on the fly and convert virtual machines form nat to bridge and vice versa: vm-bridge : convert virtual machines from NAT to bridge or bridge to NAT. I usually just execute nat2bridge without argument to create a bridge on the host default network interface before starting a guest (if the bridge is not present, you’ll get an error message and the guest won’t start).

Here’s another script to create vms on anywhere from anywhere which might interest you: vm-create : create kvm virtual machines - It would need to some updating though.

I use both scripts under openSUSE, Fedora, Ubuntu ArchLinux and Mandriva hosts - although I haven’t for a while and constantly update libvirt … so maybe I should take a closer look before posting (?). But nat2bridge should be fine.

Hmm I’ll give that a go.
I built the bridge last night according to


but it was still not working when I retired last night.

Right…script worked.

I had to delete the virtual network device first using VirtManager and get
rid of all the munging that I had done. One thing I noticed is that virbr0
is still configured. Is that a normal effect? I read here:


That it should probably be removed since I am not using NAT.

On the openSUSE server in front of me, it is gone. On another openSUSE server that I cannot reboot now, it is still there - but I haven’t rebooted it for a while. On an ArchLinux server that I just booted, it is there. I noticed the file /etc/libvirt/qemu/networks/default.xml on all machines, but on the Arch machine, there is also a symlink /etc/libvirt/qemu/networks/autostart/default.xml → …/default.xml.
The command

virsh net-undefine default

deletes the file /etc/libvirt/qemu/networks/default.xml and the virtual network device. Maybe it was removed on openSUSE by one of the many libvirt updates. Right now I have libvirt 0.9.4 and qemu 0.14.1.