Kupdateapplet Dependency Not Available?

I’m running OS 11.2, KDE 4.4 x86-32.

While I normally don’t use the Updater app, there are 2 updates showing in Yast that fail with a missing dependency: PackageKit >= 0.6.3 not available. The updates are listed for:

kupdateapplet, & kupdateapplet-packagekit

I have all the repos set up properly and updating in Yast Software Management works fine, I’d just like to clear these 2 updates out. They’ve been sitting there with blue version numbers for a couple of weeks or so, and I’m wondering if any repo’s have changed, etc?

Try this:

zypper clean -a
zypper refresh

I am having the same problem with 11.2, KDE 4.4 x86-64 and all subsequent updates to KDE, most recently KDE 4.5RC1, from the openSUSE KDE4/UNSTABLE/Desktop/ repo.

My repos are:

Index of /update/11.2
Index of /repositories/KDE:/KDE4:/UNSTABLE:/Desktop
Index of /distribution/11.2/repo/non-oss
Index of /distribution/11.2/repo/oss
Index of /pub/packman/suse/11.2

As suggested, I ran:

zypper clean -a
zypper refresh

I then rebooted and tried again with no luck.

Hope that helps.

Tried it, and its still the same. It’s not that serious, just more of an annoyance. The system works fine without it.

I think the actual version in the openSUSE 11.2 update repository is “0.5.1-3.8.1” (for i586) and according to the PackageKit homepage PackageKit - Where can I download it?
there is no stable version “>= 0.6.3”:

** Latest Supported Versions: **

These are versions which have new features for each release. We are also willing to break ABI and API to fix bugs and will merge new or modified translations as required or suggested. Releases are normally on the first working Monday of each month.
Version Date 0.6.6
2010-07-01 0.6.5
2010-06-02 0.6.4
2010-05-06 0.6.3
2010-03-29 0.6.2
2010-03-01 0.6.1
2010-02-01 0.6.0
2010-01-04**

ABI Stable Versions: **

These are versions where we will not break ABI, API or localisations. Releases are less frequent, usually every few months.
Version Date 0.5.7
2010-03-03 0.5.6
2010-01-05 0.5.5
2009-12-07 0.5.4
2009-11-02 0.5.3
2009-10-05 0.5.2
2009-09-07 0.5.1
2009-08-03 0.5.0
2009-07-06
Just two guesses:

  1. Have you (accidentally?) installed factory/unstable versions of kupdateapplet, kpackagekit or something else related to packagekit?

  2. Maybe something connected to the suggested change of kupdateapplet or to using kupdateapplet at all/kupdateaplet with packagekit went wrong?

packagekit, kupdateapplet and kpackagekit - openFATE #305394: Move KDE software updates …

Good luck
pistazienfresser