kupdate trashes grub /boot /etc/initrd /lib result temp system access via repair mode

This is a serious problem:

I had just left the forum here when kupdate applet started (thought I shut that thing down for good!) guess I was wrong. Anyways got message the 75 manditory updates some security and some recommended updates to be done. Looked over the details and nothing looked pressing …

Tried to open kwrite which crashed, tried to open openoffice-writer and it crashed too. Took gamble on kupdate and system crashed.

Used repair DVD and got this part way through the process…

initrd encountered error click to view log...
> Long wordy thing about kupdate and dbus unable to get connection
> something about changing root from /ext3 to ext2
> removing YaST modules jbd, mbcache, ext3

Repair system says ext3 system is corrupt...
>    found ext2 blocks in ext3 fs
>    No valid fstab entries
>    No initrd /etc/sysconfig/kernel
>    missing Yast modules   jbd, mbcache, ext3
> Call to mkinitrd failed
>    resolves:
>      Install symlinks in lib/mkinitrd/setup
>      Install symlinks in lib/mkinitrd/boot
>    kernel /boot/vmlinux-
>    initrd /boot/initrd-
>    root device /dev/sda6 mounted / as ext3

>    kernel /boot/vmlinux...
>    initrd /boot/initrd-
>       device /dev/sda6 not found
>    root device /dev/sda6 not found

>    initrd failed
>    bootloader config error ... repairing

Reboot to text mode boot and reports a boot error
Chose recovery -> assign /dev/sda6 as root
chose goto root filesystem
lets me in but almost all things are down

only thing that did come up fine is Firefox … go figure!

when the system started when going to root filesystem got lots of missing library references.

any help with this?

oh and web pages are incredibly slow…

Ok I re-installed openSUSE 11.2 32bit and all went ok until got kupdate applet then 5 min later system started crashing and btw it kept saying error get something from dbus.

Re-installed again this time with no network, deleted kupdate, added network, went to openSUSE repos which are not accessible as in not there! but system is now working properly

This message is for others who are having stange troubles

my system is SOLVED: don’t do update using KDE wait for openSUSE to fix repos so Yast can access them.

Kupdate has turned into total garbage.

I uninstalled the applet and update via terminal or YaST.