Kubuntu to OpenSUSE problem question

I have an HP laptop DV7 that came with two 200G hard drives. I kept the first with Windows Vista and the HP recovery partition and reformatted the second drive to use Linux.

I split the second HD into three partitions to allow me to recover easier in case of problems. A 60 GB root partition, a 140GB /home partition and a small swap partition.

I loaded Kubuntu onto the system and used it through two different upgrades of the Kubuntu KDE environment. At no time did I ever get sound to work on my laptop. Pulseaudio failed and it would default to the Intel HDA analogue but still no sound. For over a year I tried every fix that was ever written on fixing the sound under both Ubuntu and Kubuntu. I loaded GNOME over Kubuntu to try and localize the problem to something in KDE. It got very confusing but still no luck.

So I decided to try OpenSUSE. As I was loading the system onto my / partition I decided to load GNOME as my desktop. Amazingly everything worked right out of the box!! Sound was working. I loaded proprietary codecs and could play wmv files and youtube. Amazing!!

With great confidence in OpenSUSE, I downloaded RC1 (build 0334) and reloaded the system but chose KDE this time. Not everything went as expected.

  1. The default desktop loaded without a taskbar or any applications showing. I could not get the taskbar back.

  2. The sound failed with the (usual?) warning that PulseAudio failed and the system was defaulting to Intel HDA analogue (so familiar). However, the sound does work to some degree but all the sound flutters and stutters chopping up the audio.

I was able to solve the first problem by remembering that if you delete the .kde hidden folder in your home directory, the system will rebuild the .kde folder. So I did this and got the normal desktop back. So, this problem was related to kde leftovers in my /home partitions that OpenSUSE KDE was using.

However, I do not know where to go to do the same thing with the sound problem. I am pretty sure the sound problem is a leftover from the Kubuntu KDE environment. However, even on the OpenSUSE forums people were complaining about Pulseadio. So, is it or isn’t it a Kubuntu to OpenSUSE issue??

I tried going to various locations to try to find the config files to return audio to the default settings but I don’t know KDE well enough to do this.

Does anyone know how to address this problem??

My only other fix is to reload OpenSUSE and use GNOME which I know works perfectly.


A simple experiment would be to create a new user, and see if that works better…

If it does, you know the problem’s in the settings, and can either migrate to that user, or delete and recreate the first one (moving your files somewhere safe…)

I’m willing to bet the sound is fixable. I would like to say it can ONLY be made to work in openSUSE, but in truth the sort of fix we apply will likely also work in Kbuntu as well. … Still stick around, and try some suggestions I will give, and let us know how it works. There are various things to try.

The pulse audio problems are affecting every Linux distribution, but in general it can be made to work for 95% or more of the PCs, and I suspect we can get yours to work. :slight_smile: I’ve successfully helped HP DV7 users in the past, and likely I can help you.

Reference the stuttering sound, please read step#7 here SDB:AudioTroubleshooting - openSUSE step-7 - a possible fix to choppy sound and apply the work around solution recommended. Restart. Does that help?

If not, and if you still have problems, just to confirm your HP DV7 is the same as that of other’s who I have helped, assuming you are using openSUSE-11.1 please run twice the diagnostic script with your PC connected to the internet:


the first time run it as user root and select YES to update (it needs root permissions to write the update to the /usr/sbin directory). Then run it a second time as a regular user, and this time select YES to UPLOAD/SHARE question. When it completes, it will pass you a URL where the information has been uploaded. Please post that URL here. Just the URL.

And in addition to the script, when you still have problems, please also provide the output of running in a terminal:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

If using openSUSE-11.2 RC1 , then the above “cat” command will be different.

Now if the pulse “work around” helped, then please update your multimedia. Note I recommend only 4 repositories: OSS, Non-OSS, Update and Packman. Just those 4. Others can be added on an adhoc basis and then removed after. If you do not remove others as a new user you will almost certainly have problems. So just those 4. There is guidance here for that for openSUSE-11.1: Repositories/11.1 - openSUSE-Community Its likely OSS, Non-OSS, and Update are already added to your repository list and you only need to add Packman. If you have others, remove or disable them.

If using openSUSE-11.2 RC1 then the repositories will be different. Let us know if that is the case.

Once those 4 are added, you can to go YaST > Software > Softare Management, and add packman packaged applications for your multimedia. You can tell packman packaged applications by the “pm” in the version number. I typically install packman packaged versions (replacing any Novell/SuSE-GmbH packaged versions) of amarok, amarok-packman, amarok-xine, libxine1, xine-ui, xine-skins, vlc, smplayer, libffmpeg0, ffmpeg, w32codec-all, libquicktime0, … The players I prefer to use are smplayer and vlc.

That should get you started. Good luck.

Well, I tried the first suggestion and created a new user. This did not solve the problem. So, it is not a leftover from Kubuntu but a global problem caused by the hardware and the KDE environment (I think).

I have an appointment right now. So, I will try the other suggestions as soon as I get home and report the results to you all.

Thank you for the quick responses.

As to moving back to Kubuntu…I don’t think so. Ubuntu Corp. is not giving a lot of support for the KDE environment. They are a great distribution but are more focused on GNOME. Whereas, OpenSUSE is now focused on KDE. So if I can get the bugs fixed, I will stick with OpenSUSE.

In the case of openSUSE-11.2 RC1, that last command will be instead:

cat /etc/modprobe.d/50-sound.conf

Edit - Note openSUSE-11.2 RC1 is for testing (still) and will not be ready for full release for over another month. Hence I do not recommend a user install 11.2RC1 as their main system. Hence if you have 11.2 RC1, I recommend you plan on a re-install in 4 to 6 week’s time.

I am back from my appointment and I am starting to work my way through the solutions suggested by Puzzled Penguin.

First, I went to the SDB: AudioTroubleshooting step 7 link and tried to edit the /etc/pulse/default.pa file that they mention. Unfortunately, the only file in that folder is the /etc/pulse/client.conf. That file does not have the load-module command in it. So, playing with that file does not seem like a good idea at this time.

In any case, this file mentions the pulse-client.conf man page to look at. I looked…but it did not help me.

I am moving on to the next few fixes and will report back.

OK, now I have run the /usr/sbin/alsa-info.sh command, first as Root and second as user and did the upload with the user info. The link to this information is below:


Now, I am not clear whether running this script actually modified anything. Am I supposed to reboot. This is an assumption and I can’t see what harm there is so I will reboot.

But before I do that here is the result of the next set of commands:

rpm -qa ‘alsa

rpm -qa ‘pulse

uname -a
Linux linux-mzwe #1 SMP PREEMPT 2009-10-08 00:27:25 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound
cat: /etc/modprobe.d/sound: No such file or directory

Does any of this help??

I am now rebooting and will report sound status.


Oops!! I missed seeing the note about the change to the modprobe.d command. Here is the result with the new cat command:

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.Jqboh86TqAC:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

The only thing that was modified was the script was updated the 1st time you ran it.

I see openSUSE-11.2 RC1. That changes the nature of my support, and makes this harder for me, as I am not so familiar with a beta release.

I note your PC has an IDT 92HD71B7X. I could have got that working in openSUSE-11.1 by a simple update of alsa. … < sigh > … with 11.2 RC1 it will be more difficult to sort problems due to my lack of familiarity.

I am going to assume the basic sound is find, and when you report the sound " flutters and stutters chopping up the audio." can you advise which multimedia applications have that behaviour, and have that behaviour playing what media file? (ie what codecs ? )

Its important to find out soon, as if this is not application specific, then a bug report will need to be raised to get packager/developer support.

Well, the stuttering occurs with ALL sound. So, as soon as I log in the theme music that SUSE plays as the login announcement is chopped up.

Then, if I play a song using Amarok it is choppy. That’s the only music player that came with 11.2 RC1 and that is all I have loaded… Wait, I just tried Kaffeine which is a media player, and it has the same problem.

One other symptom that I have noticed is that, after pausing and shutting down the each player application, the system continues with a continuous ticking sound, sort of like a motorboating tick. This only happens if the application stays active; but if I shut it down in the taskbar the ticking finally stops.

I can load other players but I think this problem is consistent for both the system and the applications.

I am confident I can solve this in 11.1, but not in 11.2 RC1 as it has still NOT been released and bugs are still being sorted.

I recommend you raise a bug report and get the attention of a developer/packager who will be more familiar with it. There is guidance for raising bug reports here:
Submitting Bug Reports - openSUSE

Alternatively install 11.1 and we can sort it within 11.1 by a quick alsa update and a change to the file that does not exist in 11.2.

Well, i decided to make an attempt on my own before giving up and going back to GNOME.

I went looking in Yast to see what was on the system by default; especially, the pulseaudio apps. It looked like pulseaudio wasn’t loaded?? Nor were any of its support applications. So, I tried to load them and got a warning message that an existing branding package was in conflict with pulseaudio. I decided to go for it and told it to remove the conflicting package and load pulseaudio and the other related apps which I thought might be useful.

After, it completed, I rebooted and low and behold… the sound worked fine. Amarok plays perfectly with no stuttering.

I am sorry that I can name the conflicting package correctly but I did not expect this to work so I did not write it down.

So, the system now is running pulseaudio.

Strangely, when I first loaded the system on my computer I was under the impression from the error messages that it was trying to use pulseaudio and failed. Thus defaulting to the analogue fallback.

Whatever… I really don’t know what sound system is part of the 11.2 RC1. I do know that I had to load pulseaudio AFTER the fact. FYI.