kubuntu nor opensuse detect ntfs partition

so i have a main drive (320gb) which currently has kubuntu 9.04 installed.

i also have a side drive (60gb) on which i made a backup of all my windows files (i wanted to migrate to new windows OS but messed up, long stupid story…) and also had opensuse 11.0 installed.

now when i open either 2 linux versions, the ntfs partition isnt recognised anymore!!!
there are files on it that i need, including the iso of the windows version i want to install next to opensuse (just like my old windows version)

i go to sysinfo, but it’s just not there.

what do i do?

let me clarify:
opensuse is installed on the side drive, but only gets around 10GB
the rest of the side drive is filled up with the ntfs partition in question.
kubuntu was installed on the main drive

Everbody at that point would ask you to type:
sudo /sbin/fdisk -l
and post ouput.

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x092e092d

Device Boot Start End Blocks Id System
/dev/sda1 * 1 37784 303499948+ 83 Linux
/dev/sda2 37785 38913 9068692+ 5 Extended
/dev/sda5 37785 38913 9068661 82 Linux swap / Solaris

Disk /dev/sdb: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x11d311d2

Device Boot Start End Blocks Id System
/dev/sdb1 1 5355 43014006 7 HPFS/NTFS
/dev/sdb2 5484 7297 14570924 f W95 Ext’d (LBA)
/dev/sdb5 5484 5614 1052226 82 Linux swap / Solaris
/dev/sdb6 5615 6013 3204936 83 Linux
/dev/sdb7 6014 7297 10313698+ 83 Linux

seems like it does know about the partition.
thinks a bit
k i just tried to mount it, gave me an error so i forced the mount, and that worked :slight_smile:

problem solved tyvm i will try and remember that command :stuck_out_tongue:


I would run a chkdsk command on /dev/sdb1 from windows install cd or similar,You do not get two Linux systems (or any) suddenly failing to mount a partition unless the force flag is if there is no reason. Check your ntfs partition.

I should also add that because Microsoft does not like to share info, Linux has no option but to play it safe,this is also the reason I suggested Windows tools to check and repair the partition.Your Linux systems have detected something they don’t like.