Ktorrent fails to start and Plasma freeze

When I try to start Ktorrent the Plasma 5 desktop freeze, though I am able to use the open programs.
Eventually I get a dialog box saying KDEInit failed to start Ktorrent and the Plasma desktop wakes up.

If i run ktorrent on the command line I am able to start it without any problems. Though my tabs configuration are gone.
I tried to execute the ktorrent command exactly as KDEInit does and got some error output.

djviking@mintaka:~> ktorrent --icon ktorrent -caption KTorrent
Unknown options: c, a, p, t, i, o, n.
KCrash: Application 'ktorrent' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit

[1]+  Stopped                 ktorrent --icon ktorrent -caption KTorrent

When I start Ktorrent without --caption and then close it, then it output the same error again:

KCrash: Application 'ktorrent' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
[1]   Exit 253                ktorrent --icon ktorrent -caption KTorrent

[2]+  Stopped                 ktorrent --icon ktorrent

But why is my ktorrent tabs configuration gone? Even if I started ktorrent from the command line it should be using my stored configuration of ktorrent.

Looks like the KTorrent configuration has been rewritten. I am kicking my self of lacking backup.

djviking@mintaka:~> ll ./.config/ktorrentrc
-rw------- 1 djviking users 5973 02.05.2016 17:59:56 ./.config/ktorrentrc

what version of ktorrent are you using the old abandoned 4.x from kde4 or the new 5.0 from KDE:Extra?
the 4.x is abandoned and there is nothing to be done, if you are using the new maybe report this at kde’s bugzilla
ps why are you using the --caption and --icon switches?

I am using KTorrent 5.0

The --icon and --caption was something that was set up previously, perhaps for 4.x

When did they release 5.0? If it is recently then that makes sense. I still have the KDE4 ktorrentrc. Would that work with 5.0?
Edit: I copied the old KTorrent 4.x ktorrentrc and I got my tabs setup back.

djviking@mintaka:~> cp .kde4/share/config/ktorrentrc .config/ktorrentrc 

Sorry for the long reply
I don’t have ktorrent 5.0 but 4.3.1 as it was installed automaticly, and I tested the above command line and didn’t have any errors
Actually I stopped using ktorrent a few months ago when I discovered that ktorrent does not support trackerless magnet links
For example this magnet that has trackers in it’s uri works


but this same magnet without trackers does not work


Was this fixed in 5.0?
I use qbittortrent as that client does support trackerless magnets, the above uri works with qbittorrent

“–caption” is a KDE (4 and below) specific command line option, that is not understood by KF5 (or Qt5) applications. That’s a general “problem”, you’d need to use -qwindowtitle instead, or just omit it completely. It only sets the title of the window to some custom text.

“–icon” does still work, but there’s a recent bug in KF5 that causes some applications to crash on exit if it is used.
But again, there’s no need to even use that, it only sets the icon of the window to some custom one. It has been removed from most application’s menu entries when they got ported to KF5, as it should not be necessary at all. Qt5 does use the icon specified in the .desktop file by default anyway.

And yes, ktorrent 5.0 has been released a few weeks ago. See also the announcement: http://shaforostoff.blogspot.co.at/2016/04/ktorrent-kf5-release.html
Though it should migrate/import the KDE4 settings and torrents.