Kswapd issues high CPU load

Hello altogether,I have a notebook (Acer Aspire E15) with an AMD A6-6310/Radeon R4, a Crucial MX100 SSD and 8GB Ram of which 4.8GB are usable for the system. I partitionated the flash like so:

/dev/sda1       2048    321535    319488   156M EFI System/dev/sda2     321536  17108991  16787456     8G swap/dev/sda3   17108992 101001215  83892224    40G //dev/sda4  101001216 500117503 399116288 190.3G /home

Now, each time I hit the RAM limit, the system stalls and kswapd runs 100% on one core.In the opensuse-SDB there’s an article how to disable the swap to save write-cycles on the SSD. It didn’t change much. I therefore reset the swappiness to the default value.Some forums of other distributions propose to upgrade the kernel but that didn’t help all users.Is there is anything else I can do?Many thanks!Simon