ksmserver crashes, openSuSE 11.3 after upgrade to bluedevil

I upgraded to bluedevil. It required about 70 vendor changes. Now when rebooting after login, a crash message is displayed and a window opens stating “Could not start ksmserver. Check you installation.”

Any help would be appreciated.

But we have no idea what version of kde you are working with?
A list of your repos would help too

zypper lr -d

KDE:Netbook – wnload.opensuse.org/repositories/KDE:/Netbook/openSUSE_Factory
Libvdcss – ensuse-guide.org/repo/11.3
Packman_Repository – ckman.unixheads.com/suse/11.3
openSUSE_11.3 – wnload.opensuse.org/repositories/KDE/3a/Distro/3a/Factory/openSUSE_11.3
openSUSE_11.3_1 – wnload.opensuse.org/repositories/KDE/3a/Distro/3a/Stable/openSUSE_11.3
openSUSE_11.3_2 – wnload.opensuse.org/repositories/KDE/3a/UpdatedApps/openSUSE_11.3
openSUSE_11.3_3 – wnload.opensuse.org/repositories/KDE/3a/Extra/openSUSE_11.3_KDE_Distro_Factory
repo-non-oss – wnload.opensuse.org/distribution/11.3/non-oss/
repo-oss – wnload.opensuse.org/distribution/11.3/oss/
repo-update – wnload.opensuse.org/update/11.3/

This information is garbled and makes no sense
Please use the code I gave you and report the result in code too.

Just looking, why do you have a mix of stable and Factory?
But I’d like to see the proper results
I’m off to sleep now :smiley:

Sorry, I missed that repository URL wrapped. The repositories are:

Index of /repositories/KDE:/Netbook/openSUSE_Factory
http://opensuse-guide.org/repo/11.3
Index of /suse/11.3
http://download.opensuse.org/repositories/KDE/3a/Distro/3a/Factory/openSUSE_11.3
http://download.opensuse.org/repositories/KDE/3a/Distro/3a/Stable/openSUSE_11.3
http://download.opensuse.org/repositories/KDE/3a/UpdatedApps/openSUSE_11.3
http://download.opensuse.org/repositories/KDE/3a/Extra/openSUSE_11.3_KDE_Distro_Factory
http://download.opensuse.org/distribution/11.3/non-oss/
http://download.opensuse.org/distribution/11.3/oss/
Index of /update/11.3

As to the mix, I hoped it would upgrade to KDE3.5, however it has not. Its at KDE 3.4.

You still did not give what was asked for the output of zypper lr -d

Also if you select go advanced in this editor you can put code tags around the text to it does not get reformatted

You problem is you mixed version thus you have somethings from 3.4 and 3.5 and possibly what ever happens to be in factory

Never mix never worry.

Posting in Code Tags - A Guide

https://www.youtube.com/watch?v=QL-CDbKxvx0)

I appreciate your request. Here’s the story. The computer in question is a netbook. It isn’t mounting a USB thumb drive. So, while I can take the output of the zypper command write it to a file, I can’t get the file off the netbook to the computer I’m using to post this. What I’ve typed for you are the URLs for the repos enabled. All these are enabled. All have priority 99. All have refresh enabled. If you can’t work with this, I’m not sure what more I can do.

Since its getting into the weekend, I will disable some of the repos. However, this is unlikely to resolve the issue as the problem is probably a mismatch of various KDE components. I may need to reinstall KDE. What’s odd is that I attempted to do this with the thumb drive used to install SuSE 11.3, and now it doesn’t work. It stops because the drive is read only.

Thanks for all the help.

KDE:Netbook – wnload.opensuse.org/repositories/KDE:/Netbook/openSUSE_Factory
Libvdcss – ensuse-guide.org/repo/11.3
Packman_Repository – ckman.unixheads.com/suse/11.3
openSUSE_11.3_1 – wnload.opensuse.org/repositories/KDE/3a/Distro/3a/Stable/openSUSE_11.3
repo-non-oss – wnload.opensuse.org/distribution/11.3/non-oss/
repo-oss – wnload.opensuse.org/distribution/11.3/oss/
repo-update – wnload.opensuse.org/update/11.3/

Modify to leave as above

Then run this as su -

zypper dup

I had a similar problem a couple weeks ago when I was upgrading software. The person who I talked to told me this:

Please do the following as su -

zypper rr 2
zypper rr 1

Now this:

zypper dup

Once done. Reboot
Select kde at the login screen and report back

Thanks caf4926. Your solution worked.

That’s great news!