KsCD won't play CDs in SATA drive

This query started out (see the Applications>>Multimedia forum) as a problem with KsCD not playing CDs, although it could see and identify the CDs OK. The CD drive I was using (which works OK - I used it to install OpenSUSE 11.1 earlier today) is a new SATA one.

I have now added an old IDE DVD drive (with sound cable), and my CDs play fine in this. Why will KsCD not play using my brand-new SATA DVD drive? Is there an alternative app to KsCD which will allow me to play CDs on the SATA drive?


I have sata drives as well.

I have been fighting the KsCD beast, and I think I have won at least for the current boot session. I’ve been struggling with this for the past 3 days. I’m tired and I ask myself if KsCD is worth the trouble. But, it’s included, and I like everything to work.

What is funny is last week I did manage to get sound out of KsCD after my initial install of openSuse KDE4 64-bit and did the patch updates (still no sound from kscd) and then tried the restricted multimedia rpms from Packman. This installed various codecs and licensed stuff, some of which I didn’t really want, but I let it install the whole lot so I could see what it would fix with various multimedia playback. So, toward the end of this week, and after doing reinstall and re-retrieving again the patches and recommended updates I found I had no sound from KsCD again, so I looked at things like Kmix. It is set correctly with volume up, master channel selected as “front”. I get system sounds, well, all but start up system sound, I can hear the audio cd when I play it with kaffeine, so what’s up with Kscd? I then read old problems with Kscd and it needing the old-fashioned analog cable connected between the cdrom and the sound card, but I knew it could play via digital playback and it is a choice under kscd’s settings, so…

I then went to the Multi-media restricted formats link and looked over the one-click suggested multimedia rpms, but I had some of those recommendations aleady installed, like Adob. Flash-Player and Fluendo-MP3, which is in the basic default repositories. eh, I hesitate to use one-click, and I didn’t want to add Packman repo, so I looked in Package Manager to see if any of those suggestions were already in the default repos. Yes, phonon-backend-xine is. So, I first did a repo refresh, installed today’s recommended patches (mdadm, translation-update) and then installed phonon-backend-xine.

I KsCD>eExtras>Settings&Behaviour>and made sure “use direct digital playback” was ticked. I also made sure I had selected the correct CD drive as I have two optical DVD/CD burners.
I put the disk in, started up kscd and hit play and I could hear it! The only trouble now is, kscd will not spit out the disk if I click “eject”, but I can manually eject it.

I also get a pop-up message from phonon saying “The audio playback device: c-media oxygen HD (rev2) (analog) doesn’t work. Falling back to c-media oxygen HD (rev2) (digital)” when I test system sounds under Configure Desktop>Notifications and now get no system sounds, whatsoever.

I’ve only tried this today and it is flaky. So far, I have to untick, “use direct digital playback”, and “apply” and then do it over again: tick “use direct digital playback” and “apply”, “play”, and I can hear the speaker make a click noise and a second later the tune plays.

I’m confused over how to set up Configure Desktop>Sound>Device Preference as well as Backend. There is Audio Output which is what I hear, and Audio Capture. I don’t use a microphone, or headphones.

If you hover your cursor over the different settings while in menu, there are descriptions of what each means, such as, “Audio Output” defines the default ordering of devices which can be overridden by individual catagories

Hovering cursor over each selection for notifications shows:

This will try the following devices and list the first that works:

  1. x-phonon=CARD=0=,DEV=0
  2. plughw=CARD=0,DEV=0

This will try the following devices and list the first that works:

  1. x-phonon=CARD=0=,DEV=1
  2. plughw=CARD=0,DEV=1

xine audio ouput plugin using pulseaudio soundserver

This will try the following devices and list the first that works:

My snapshot is shown below in album: sound. I made sure I clicked on “Apply Device List To…” and unticked everything while while under Music heading, then applied. If I go to Backend and switch back to the default gstreamer backend, it lists even more advanced devices which I have no idea what they are. But, at the moment, I have backend set to xine. I’m bleary-eyed and confused, as I’m trying to fix something that I just need to ignore and be happy that kaffeine plays. I’m sure all this will get fixed right in the future. There’s a few bug reports on kscd and phonon in the latest kernel with kde4.

http://my.inbox.com/photos/s2dhc5knt (album:sound)

Don’t mind me, just updating what I went through earlier. Well, it was worth it, especially since I took a long walk in the hills and now can relax with a glass of…

It seems adding the phonon-backend-zine did the trick. What made the difference in keeping system sounds and being able to play an audio cd via KsCD is knowing what to choose in sound system configuration>device preference>Audio output for each catagory…and, make sure you click on “Apply Device List To…” and untick all those that you do not want to change.
For notifications, like system sounds, each time I logged in I would get the phonon “reverting from analog to digital message.” This time I went to Configure Desktop>Sound>and put CMedia Oxygen HD Audio (Digital) and “prefer” 'ed it to the top of the list. This seems to be working. Now, the only time I do not get system sounds is if KsCD is running. I have to quit it from the kicker panel and then I can hear sounds when I test the system notifications. So, KsCD can’t scratch its head and pat its tummy at the same time, or maybe it is system sounds that cannot. :wink: Sorry if this bewildered anyone. I was dead tired before, and now I’ve had a glass of…and am enjoying, via KsCD, Suite for Violin and Jazz Piano, by Claude Bolling.

This post is what got my started on my dragon slaying KsCD fight: No Sound; OpenSuse 11.1; Satellite 64-bit; Radeon - Page 4 - openSUSE Forums Thanks David2009!