KRDC can't connect to RDP (Windows 7)

So I installed Leap 15.0 on Saturday (26.05) on my HP Probook 450 G3. I did a fresh install including formatting /home partition. Only settings I copied from previous version were DBeaver, Firefox and Thunderbird.

So that’s it for opening. Now to my problem.

I have a virtual machine with Windows 7 on my server and I use(d) KRDC to connect to it from my laptop (over RDP). Everything worked just fine on Leap 42.3 (with only one problem which appeared to be a bad Windows update) but when I updated to Leap 15 I just can’t connect to that machine.
When I try to connect it would ask for a password and after typing a correct one it would just blink and go back to the KRDC’s main window. When I start KRDC from Konsole and then try to connect there is no output.
I tried connecting with Remmina - it worked just fine
I tried connecting with xfreerdp - it worked just fine
I tried updating KRDC with KDE Applications repo - no luck.

My dad had the same issue on HP Probook 470 G5 but he went back to Leap 42.3 and there it is working with no problem (even with updated plasma).

For now I’m using Remmina but I prefer KRDC so I’m hoping for your help. Let me know what kind of logs I should give you.

AFAIK KRDC uses xfreerdp. So it is strange, that xfreerdp works and KRDC not.
You should try to get the console debug output with the xfreerdp call:

QT_LOGGING_RULES="*.debug=true" krdc

Then post the xfreerdp call here or try this call on the command line yourself and play with the options.


I have same problem. My first hardware computer have fresh install Leap 42.3 (at office) with Xen-virtual fresh install for test Leap 15 (on date May, 29) and second hw comp updating from Leap42.2 to 15 (at home, on date May, 27). In Leap 42.3 (at office) all ok. In virt and home Leap 15 problem like this - KRDC splash blue screen and return to connect dialog with single host without any output or error.
I’m installing Remmina at home on Leap15 - it’s work fine.
Now at work i do like in reply :

user@linux-ko3g:~> QT_LOGGING_RULES="*.debug-true" krdc

It work with error. I don’t find any log krdc in /var/log , including text search in files. Where it find ?

user@linux-ko3g:~> xfreerdp /u:user /p:w0rd /w:1024 /h:800 /v:mywin7comp.loc
[09:27:38:581] [4308:4309] [INFO][com.freerdp.client.common.cmdline] - loading channelEx cliprdr
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - @ WARNING: CERTIFICATE NAME MISMATCH! @
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - The hostname used for this connection (mywin7comp.loc)
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - does not match the name given in the certificate:
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - Common Name (CN):
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - win7
[09:27:38:676] [4308:4309] [ERROR][com.freerdp.crypto] - A valid certificate for the wrong name should NOT be trusted!
Certificate details:
Subject: CN = win7
Issuer: CN = win7
Thumbprint: _____________
The above X.509 certificate could not be verified, possibly because you do not have
the CA certificate in your certificate store, or the certificate has expired.
Please look at the OpenSSL documentation on how to add a private CA to the store.
Do you trust the above certificate? (Y/T/N) y
[09:27:49:999] [4308:4309] [ERROR][com.winpr.timezone] - Unable to get current timezone rule
[09:27:49:208] [4308:4309] [INFO][com.freerdp.gdi] - Local framebuffer format PIXEL_FORMAT_BGRX32
[09:27:49:208] [4308:4309] [INFO][com.freerdp.gdi] - Remote framebuffer format PIXEL_FORMAT_RGB16
[09:27:49:230] [4308:4309] [INFO][com.winpr.clipboard] - initialized POSIX local file subsystem
[09:28:08:707] [4308:4309] [INFO][com.freerdp.client.x11] - Closed from X11

All OK, connected.

I see the output in the console window, like this:

 QT_LOGGING_RULES="*.debug=true" krdc            
No protocol specified
qt.qpa.screen: EDID data for output "eDP1": identifier 'B173HAN01.0', manufacturer 'B173HAN01.0',model '', serial '', physical size: 380.00x210.00
qt.qpa.screen: Output HDMI1 is not connected
qt.qpa.screen: Output VIRTUAL1 is not connected
qt.qpa.screen: adding QXcbScreen(0x555e5681ef20, name="eDP1", geometry=1920x1080+0+0, availableGeometry=1920x1044+0+0, devicePixelRatio=1.0, logicalDpi=QPair(96.0,96.3), physicalSize=380.0x210.0mm, screenNumber=0, virtualSize=1920x1080 (1920.0x1080.0mm), orientation=Qt::ScreenOrientation(LandscapeOrientation), depth=24, refreshRate=60.0, root=167, windowManagerName="KWin") (Primary: true )
qt.qpa.screen: primary output is "eDP1"
qt.qpa.input: Plugin build with support for XInput 2 version up to 2.2
qt.qpa.input: Using XInput version 2.2
qt.qpa.input.devices: input device  Virtual core XTEST pointer ID 4
qt.qpa.input.devices:    has 10 buttons
qt.qpa.input.devices:    has valuator "Rel X" recognized? true
qt.qpa.input.devices:    has valuator "Rel Y" recognized? true
qt.qpa.input.devices:    it's a scrolling device
qt.qpa.input.devices: input device  PixArt HP USB Optical Mouse ID 10

But I’m using Tumbleweed and have additionally the debug packages installed (krdc-debuginfo-18.04.1-1.1.x86_64)



I find krdc-debuginfo only for FC28 . Sorry, system output in russian

user@linux-ko3g:~> QT_LOGGING_RULES="*.debug-true" krdc


user@linux-ko3g:~> sudo zypper search krdc

С | Имя | Заключение | Тип
i+ | krdc | Подключение к удалённому рабочему столу | пакет
i+ | krdc-debuginfo | Debug information for package krdc | пакет
| krdc-devel | Development files for krdc | пакет
i | krdc-lang | Translations for package krdc | пакет

[FONT=courier new]
user@linux-ko3g:~> sudo zypper info krdc

Сведения — пакет krdc:

Репозиторий : openSUSE-Leap-15.0-Oss
Имя : krdc
Версия : 17.12.3-lp150.1.3
Архитектура : x86_64
Поставщик : openSUSE
Размер после установки : 971,6 KiB
Установлено : Да
Состояние : актуален
Пакет с исходным кодом : krdc-17.12.3-lp150.1.3.src
Заключение : Подключение к удалённому рабочему столу
Описание :
KRDC позволяет подключиться к VNC и RDP-совместимым серверам.

user@linux-ko3g:~> sudo zypper info krdc-debuginfo

Сведения — пакет krdc-debuginfo:

Репозиторий : @System
Имя : krdc-debuginfo
Версия : 17.12.3-1.fc28
Архитектура : x86_64
Поставщик : Fedora Project
Размер после установки : 3,9 MiB
Установлено : Да
Состояние : актуален
Пакет с исходным кодом : krdc-17.12.3-1.fc28.src
Заключение : Debug information for package krdc
Описание :
This package provides debug information for package krdc.
Debug information is useful when developing applications that use this
package or when debugging this package.



deceived myself >:(

Going to read logs…

Resolved ! There are in output debug: KRDC: Starting xfreerdp with arguments: “-decorations /w:1024 /h:768 /kbd:0x00000409 /u:user /parent-window:818905 /bpp:16 /audio-mode:2 /drive:media,/media /network:broadband /admin /rfx /cert-ignore +clipboard /port:3390 /v:mywin7.loc” If I manually send this command in console, xfreerdp output his help. Ups, some arguments are wrong ! After some iterations I find it - /drive:media,/media / If I send command without this, xfreerdp is connected ! And If I erase this field in connection properties in KRDC, it’s work too ! Yes, I did it ! PS. And quote “/drive:media,/media/” not work :frowning:

Good to hear, that it works now!
It is a known issue (upstream) that xfreerdp just quits, when it should redirect a folder, that doesn’t exist.


I confirm that. Turned out /media directory wasn’t present so creating it fixed a problem.