KPowerSave reverted to default language

I don’t know what I did, but the kpowersave menus in my system tray somehow lost their localized settings and reverted to English. I checked the other users on my SuSE and they still have their localized versions, so the required system files are obviously still present on the system. I tried to copy their setting over to my ~/.kde/share/config/kpowersaverc, overwriting my old settings, but that changed nothing – apart from making me lose my customized power schemes.
Anyone know how I can get my localized menus and dialogs back?

OpenSuSE 11.0 with KDE3.5.9, localized to Slovenian.

I would check in the Control Center. I’m using kde4.2beta at the moment, so can’t just check.

I’m surprised you have not added the kde3 build service repo. I use it and you get 3.5.10
It’s rock solid.
Index of /repositories/KDE:/KDE3/openSUSE_11.0

thanx for the reply. I’ve tried to reset my regional settings in Control Center (setting them back to English, rebooting, setting them to Slovenian, rebooting) but to no avail. I must specify that the problem is exclusively with KPowerSave – no other regional settings are lost anywhere – and exclusively with my user account – all other users have KPowerSave in Slovenian.
As to your repo suggestion: I am pretty much a newbie to all things GNU/Linux, so my knowledge is very lacking in essential things, such as why there are so many repositories, how do they interact, why are they sometimes incompatible, what is a build service for, exactly. I’ve yet to come across a concise, to-the-point FAQ or howto about repositories. I’ve even posted a question about repositories/updates on these very forums (Can you set ATI repository to auto-update? - openSUSE Forums) that is quite revealing of my newbness in this regard. What I particularly miss is a tutorial about the underlying philosophy of the repository system, so for the time being I just stick to the 3-4 community recommended repositories. The other reason is, I’m primarily after a no-frills, sturdy system, and I’ve been told – and experienced it myself – that by enabling many repositories you quickly compromise that.
But, more to the point: wouldn’t a build service mess up my localization even more, given that localization in general notoriously lags behind the English releases, in the sense that the more bleeding-edge your release is, the less likely it is to have a complete localized version available? As an illustration: I had to update ktorrent to a newer release because of it crashing all the time. Now it doesn’t crash anymore, but – needless to say – it’s also not localized anymore, it’s entirely in English.

You will have no trouble with the kde3 repo I suggested. Some Build Service repo’s are unstable or can cause conflicts with other repo’s. But the kde3 repo I suggest will just give you the latest stable release of kde3, different to that shipped with the version od OS you are using.

Re; KPowersave

Delete it - All of it including any files in hidden /home/user/.

then re-install

Followed your advice, uninstalled kpowersave and kpowersave-lang, deleted kpowersave remnants in my home dir, rebooted, reinstalled both packages – to no avail. Running pretty much out of options here… Even tried to revert my system localization to English in KDE Control Center, and then reinstate back to Slovenian. Again, no effect whatsoever…

Did you check here

But here is an idea.
Have you tried to either create a new user
or do a re-name on your .kde (to .kdeold)
re-login and see if the problem remains

This will at least help you determine if the problem is user or system wide.

You can revert back to your old folder easy enough.

Thanx for sticking with me for so long. I followed both your suggestions. First, I renamed the two locations in /opt/kde3… you’ve given above: the only result was that KPowerSave lost its icons.

Second, I created a new user: his KPowerSave was localized to Slovenian. So the thing is not system-wide.

All in all, still no go. I’m beginning to suspect there must be a daemon/program I’m running at startup and that other users don’t run, which interferes with KPowerSave. I’ll try googling it some more. I just can’t believe I’m the only one who’s bumped into this issue. Oh well, it’s not a major issue anyway.

I didn’t suggest re-name /opt/kde3, I just said look at them.

I said rename .kde it’s your hidden user settings for kde

Put /opt/kde3 back to normal

Try a rename of .kde to .kdeold

When you login again under your user name, kde will be like first use.

So you have to re-do all your desktop settings

you might be able to re-name it from a icewm login
or from a CLI
mv /home/uernme/.kde .kdeold

Although I was reluctant to rename my .kde (I would lose over 360 MB of highly personalized settings) just like that, your suggestion did put me on the right path. Proceeding by exclusion (logging out, renaming one .kde subdir, logging back in, renaming another subdir, and so on) I slowly managed to narrow down the culprit to the ~/.kde/share/config folder. Then, I compared the filesizes of the files in ~/.kde/share/config to the filesizes in another user’s directory. That way, I succeeded in further narrowing down the culprit to just a handful of config files located in ~/.kde/share/config. I proceeded to remove those and then put them back one by one, logging in after each one to see the effect. I soon found out that the file kdeglobals was the critical one. I looked inside it and quickly discovered a line that was highly suspect (it was referring to languages and was different from the other user’s): it was apparent that I had left a “fallback” language when setting up my locale, whereas the other user had deleted the fallback and only left the correct locale. To check this theory, I went to Control Center > Regional Settings and Accessibility > Region and Language and deleted the fallback language which was English. And bingo! – my localized menus in KPowerSave were finally back!

Thanx for leading me in the right direction!

Great and well done!!