kpilot conduit problems

kpilot worked just fine with my Palm Tungsten T3 on OpenSuse 10.3. I recently upgraded to 11.2 and have had numerous problems. It took me a while to get the hardware talking (documented in another thread), but now the sync is proving to be problematic. A hotsync happens - and I can also sync fully with jpilot, but the sync isn’t going anywhere. I’m hoping to sync with kontact, but it’s impossible to tell as kpilot hangs whenever I try to configure the conduits through the “Configure kpilot” menu item.

When syncing, the log complains of missing conduits:
Version: KPilot 5.3.0 (KDE 4.3.0)
Version: pilot-link 0.12.3
Version: KDE 4.3.1 (KDE 4.3.1) “release 6”
Version: Qt 4.5.3

HotSync Log

10:17:13 Starting the KPilot dæmon …
10:17:13 Dæmon started.
10:17:13 Dæmon status is `.kde.kpilot.daemon was not provided by any .service files’
10:17:14 Next HotSync will be: Copy Handheld to PC. Please press the HotSync button.
10:17:14 Pilot device /dev/pilot does not exist. Probably it is a USB device and will appear during a HotSync.
10:17:20 Checking last PC…
10:17:20 KPilot 5.3.0 (KDE 4.3.0) HotSync starting…
10:17:20 Using encoding ISO-8859-15 on the handheld.
10:17:20 [File Installer]
10:17:20 No Files to install
10:17:20 [Conduit kpilot-conduit-calendar]
10:17:20 Error: No valid akonadi collection configured.
10:17:20 One of the data proxies could not be initialised.
10:17:20 The conduit Calendar Conduit could not be executed.
10:17:20 [Conduit kpilot-conduit-todo]
10:17:20 Error: No valid akonadi collection configured.
10:17:20 One of the data proxies could not be initialised.
10:17:20 The conduit To-do Conduit could not be executed.
10:17:20 [Conduit kpilot-conduit-contacts]
10:17:21 Error: No valid akonadi collection configured.
10:17:21 One of the data proxies could not be initialised.
10:17:21 The conduit Contacts Conduit could not be executed.
10:17:21 [Conduit time_conduit]
10:17:21 Setting the clock on the handheld
10:17:21 [Conduit memofile-conduit]
10:17:21 Syncing with /home/christian/MyMemos.
10:17:21 Doing regular sync…
10:17:21 Backup directory: /home/christian/.kde4/share/apps/kpilot/DBBackup/Christian Mayne/.
10:17:21 Full backup started.
10:17:21 Backing up: ContactsDB-PAdd
10:17:26 Full backup complete.
10:17:26 End of HotSync

The kpilot page here KPilot Homepage suggests deveolpment on kpilot has stalled.

So, with the interface hanging, I’m looking for alternate ways of configuring (or syncing with kontact)

Many thanks


have you had any progress on this issue? I’ve run into the same problem. Upgraded to openSUSE 11.2 and am trying to sync my Palm (actually a Sony Clie) with Kontact using KPilot.

Everything worked fine under openSUSE 11.1, but now I get either of the following two scenarios:
(a) If KPilot is started already and I try to sync, no connection is made and KPilot doesn’t recognize my device.
(b) If I start the Hotsync first and then open KPilot, I get the error message:

Pilot device /dev/ttyUSB0 is not read-write.

I can work around the problem of the second scenario by making /dev/ttyUSB0 read-write using chmod 666 /dev/ttyUSB0, but this only works for one sync, hence is a very cumbersome solution …

Hi there.

There is no write privileges for the user on /dev/ttyUSBx devices. Try this as root:

chmod 777 /dev/ttyUSBx


If I understand correctly, there are two questions:

  1. kpilot hanging

I had the same problem: kpilotdaemon hanged after some seconds if the Palm was connected. I used to resolve this configuring conduits through
Kontact -> Settings -> Configure Kontact -> Kpilot
in this way you can configure kpilot without starting kpilotdaemon. When you are ready, you start the daemon and sync.

  1. missing conduits

Maybe this issue is related to akonadi. Since some versions back, kpilot syncs through akonadi resorces. You have to define them. Once this is done, it used to work fine for me.

I say “it used” because kpilot it’s not in KDE 4.4, which is the version I’m running now. I understand that kpilot it’s discontinued. I’m now syncing with jpilot (which works fine), but I prefer to sync with kontact and I’m looking for a way to do it.

I had the same problem. It used to work perfectly on openSUSE 11.1 but now in 11.2 it freezes when I try to configure it.

What I did is install the KDE3 repo for 11.2 and installed kpilot for kde3. now I can set everything but I can get any port to work. I have tried ttyUSB0, ttyUSB1, /dev/pilot nothing seems to work.ttyUSB1, which is the one I used to use says is not a read-write.

Any clues?:\

OK, so I got it to work with kpilot kde3, but the problem is that I was only able to do it as root. How can I do it as user instead?:\

Have you tried usb: as port? It used to work perfectly for me.