Korganizer crashes when entering new event

I am running korganizer 5.6.90 rc under Frameworks 5.40.0 and Qt 5.9.3. Since the install of 17.11.90-41.3 on Saturday, the program crashes when entering a new event, new todo or new journal. I have all the requisite auxiliary programs, such as kdepim-addons, installed and everything was working fine before the latest update. When I ran the program from a console window, I received the following messages upon opening the program

KServiceTypeTrader: serviceType "KOrganizer/Part" not found

and the following messages following the crash:

rg.kde.pim.korganizer: No valid person found for QModelIndex(0,0,0x2c58510,QSortFilterProxyModel(0x29f20b0, name = "sortproxy"))
KCrash: Application 'korganizer' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit

[1]+  Stopped                 korganizer
charlie@Beary:~> QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 15 and type 'Read', disabling...
QSocketNotifier: Invalid socket 10 and type 'Read', disabling...
QSocketNotifier: Invalid socket 16 and type 'Read', disabling...
QSocketNotifier: Invalid socket 18 and type 'Read', disabling...
QSocketNotifier: Invalid socket 11 and type 'Read', disabling...
QSocketNotifier: Invalid socket 24 and type 'Read', disabling...
QSocketNotifier: Invalid socket 17 and type 'Read', disabling...
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
QSocketNotifier: Invalid socket 14 and type 'Read', disabling...
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
[1]+  Segmentation fault      (core dumped) korganizer

I can’t find anything in Bugzilla, so I’m wondering if it is something I did?

I’ve now refreshed the akonadi database and have had an update to the program. I’ve made sure there are no unconfigured calendars referenced as suggested in a semi-related bugzilla entry and checked dependencies… No joy. Still having the same problem. Is there anything else I can do?

I’ve ascertained that it is the event editor that might be the problem. I was able to accept an e-mailed invitation and it was written to my calendar with no problem after clicking the accept button. So the issue is not with my ics file. After several updates the problems persist. Perhaps a dependency?

Have you submitted a Bug Report to the KDE folks?
Did DrKonqi provide a crash dump?
[HR][/HR]Please be aware that, you’ll need to do the following:

  1. Register as a KDE Bugtracking System user: <https://bugs.kde.org/> (There are some guidelines for your e-Mail account name – it’s strongly suggested that, you do not use your “normal” e-Mail address – if your ISP provides the service, setup a new e-Mail account which will only be used for things such as Bug reporting.)
  2. When DrKonqi pops up (the red with black spots Bug icon – a Coccinellidae), check the crash dump trace and, take notice of the message “insufficient information” – there’s an “install debug symbol packages” button – do it before continuing with the submission of the Bug Report.
  3. At a point in the submission procedure, DrKonqi will attempt to check for already submitted (by other people) similar Bug Reports – enter your KDE Bugzilla user’s e-Mail address and password and, choose to let DrKonqi store this pair in KWallet – a KWallet Form Data pair named “drkonqi_bugzilla” will be automatically created and afterwards life is much easier . . .
  4. Choose a suitable title for your Bug Report: a title such as “Kontact (kontact), signal: Segmentation fault – PimCommon::ConfigurePluginsListWidget::slotConfigureClicked(QAction*)” makes life easier for the KDE folks to classify your Bug Report.

Thanks, I’ve just done that. I’ll see if I get a response.

I wouldn’t think so, since this is a user-caused situation: you added unstable repos and have ended up with a mix of KDE/KF5/Qt packages where versions mismatch.

Please, quote the KDE Bugzilla number associated with your report.

May, possibly, have found the KDE Bug Report: <https://bugs.kde.org/show_bug.cgi?id=388019> “Korganizer crashes when choosing enter new event.”

Application: korganizer (5.7.0)

Qt Version: 5.10.0
Frameworks Version: 5.40.0
Operating System: Linux 4.4.103-36-default x86_64
Distribution: “openSUSE Leap 42.3”

And, given the Crash Handler report:

#6  EventViews::AgendaView::placeDecorations (this=this@entry=0x184d740, decoList=..., date=..., labelBox=labelBox@entry=0x18ab550, forWeek=forWeek@entry=false) at /usr/src/debug/eventviews-17.12.0/src/agenda/agendaview.cpp:1136
#7  0x00007fde7da6e9b6 in EventViews::AgendaView::createDayLabels (this=this@entry=0x184d740, force=force@entry=true) at /usr/src/debug/eventviews-17.12.0/src/agenda/agendaview.cpp:1265
#8  0x00007fde7da6f76b in EventViews::AgendaView::init (this=this@entry=0x184d740, start=..., end=...) at /usr/src/debug/eventviews-17.12.0/src/agenda/agendaview.cpp:839
#9  0x00007fde7da6fd38 in EventViews::AgendaView::AgendaView (this=0x184d740, start=..., end=..., isInteractive=<optimized out>, isSideBySide=<optimized out>, parent=<optimized out>) at /usr/src/debug/eventviews-17.12.0/src/agenda/agendaview.cpp:722

IMHO, the KDE developers may very well reply to this report within the next few weeks. (They’re also entitled to a Christmas break!)
[HR][/HR]BTW: The KDE “End-of-year Fundraiser” is currently active: <https://www.kde.org/fundraisers/yearend2017/> and <https://dot.kde.org/2017/12/19/kde-end-year-fundraiser-2017-live>.

Don, if they get the full report, incl. unstable repos, they (IMNSHO) should not even reply, We can only support the distro, not the exotic combos of repos users think they should use. My 2 cents

I only went to the version I did because the KMail included in the distro lost some functionality compared to the previous version if I recall correctly. I followed instructions from this forum and it must have been successful because I did it about six months ago and everything has worked perfectly from that time until December 9.

Unfortunately, the KDE folks only get to see the distro and the versions:

Application: korganizer (5.7.0)

Qt Version: 5.10.0
Frameworks Version: 5.40.0
Operating System: Linux 4.4.103-36-default x86_64
Distribution: "openSUSE Leap 42.3"

-- Information about the crash:

  • If the custom versioning doesn’t behave as it should do, roll back to the “default” versions for the release.
  • Yes, the repository “KDE:Extra” can be used for newer versions of KDE applications but, be aware that, KMail isn’t offered by that repository.

It started to be impossible to link Korganizer with Google calendars. That was the last straw. I rolled back and everything works as it should. Lesson learned.