Korean/English toggle typing

My wife needs to be able periodically to type in Korean and I can’t find where I can set the keyboard.
Hopefully it will be similar to Windows in that she can toggle English/Korean.

Well NUTS !!!

I forgot this:

openSUSE 12.3
KDE 4.10

Just installed today.

Run “Configure Desktop” and select “Hardware”->“Input Devices”->“Layout”.

Enable “Configure layouts” and click on “Add…” to add additional layouts:
http://wstaw.org/m/2013/08/22/systemsettings_kbdlayout.png
After clicking on “Apply”, a Layout switcher should appear in the system tray (lower-right next to the digital clock).
Left-click on that to cycle between the layouts, or right-click for a menu.
You can also configure keyboard shortcuts for switching the layout or changing to a certain layout.

Well, I got it to toggle but the preview and any typing that I do are in arabic.
Do you have to do anything more special ?
Should it work in a text document ?

thanks

You may need to install Korean fonts. Sorry don’t know which ones. But if you do a search in yast on Korean you will see many packages that may help. There is also a KDE4 package. Maybe some else can give you more direct help.

I have set it aside for now and will get back to it tomorrow. I didn’t think to do a search in yast, so that will be 1st thing tried.
Am I correct in assuming that when I press the preview button, and it shows a keyboard, that the Korean characters will be displayed ?

Sorry no idea I only use English. But Linux in general is pretty good with multiple languages but you do have to install the needed fonts since only the install selected language stuff gets loaded unless you specify otherwise

Well, I don’t know, never used Korean or something like that.
But that just switches the keyboard layout of course.
Maybe you have to install fonts that support Korean as well?

Hm, actually, setting Korean just seems to switch to a standard US layout on my system. The same happens if I switch the system keyboard to Korean in YaST.
So maybe there’s some other package missing as well.

Googling seems to suggest scim or ibus could help. So maybe install the packages scim-qt4, scim-hangul and scim-tables-ko (or ibus-qt and ibus-hangul) ? Maybe you need some more?
But as I said, I have absolutely no experience with that, so cannot help you, sorry.

I assume you at least have used YaST > Software > Software Management and then chosen Languages from the View button and then checked ko (Korean) for installation?

Yes, I did install the additional language in Yast.
I am now looking around for, and I found 1, for libhangul1.

Question:
Do I need to find one for opensuse 12.3 ?

I think I saw one for opensuse 12.2 and would that work ?

Well, If I interprete it correct, there is a libhangul1 in the OSS repo for 12.3.
Can’t you find it? Type hangul in the Search field of YaST > Software > Software management.

The search doesn’t turn up anything.
And I swear that I installed one named libhangul1, also unde add-ons, ibus.

Does the search treat the ***, asterisk wild card like other systems ?

I did a search for libhan* and still no results.

Yet the history file shows this:


2013-08-22 09:09:11|radd   |PK_TMP_DIR|dir:///var/tmp/TmpDir.agDAmk|
2013-08-22 09:09:18|rremove|PK_TMP_DIR|
2013-08-22 09:09:40|radd   |PK_TMP_DIR|dir:///var/tmp/TmpDir.IoOb2v|
2013-08-22   09:09:49|install|libhangul1-32bit|0.1.0-5.1.1|x86_64||repo-oss|693ff9e0010b719b95fe10aeccd822c322bcdaa6b5c83c5eb52aba3bb0d1d99a|
2013-08-22   09:09:49|install|libibus-1_0-0-32bit|1.4.2-4.10.1|x86_64||repo-update|582c762cb79d11d939813288e37fb4dc0146fa6b30b632c3e061088184a692e0|
2013-08-22 09:09:54|install|ibus-hangul|1.4.1-1.1.2|i586|root@linux-ntwr.site|PK_TMP_DIR||
2013-08-22 09:09:55|rremove|PK_TMP_DIR|
2013-08-22 09:21:58|radd   |openSUSE:Factory|http://download.opensuse.org/factory/repo/oss/|
2013-08-22   09:29:16|install|libhangul1|0.1.0-5.1.1|x86_64|2545:y2base|repo-oss|de3c8b6b5eb06a24d3f0999b1a56ead8d32ebb3b16f009f1894dc76076280f0e|
2013-08-22   09:46:58|install|libreoffice-icon-theme-crystal|4.1.0.4-3.1|noarch||openSUSE:Factory|072ed81318cbdd3a82afa39d6d61ba15d047a3eb9b56732102cd6313c8ebe90d|
2013-08-22   09:46:58|install|libreoffice-icon-theme-galaxy|4.1.0.4-3.1|noarch||openSUSE:Factory|8bc2d061694e1f0ae61b41d45b7c2aae075ea7005cf45c348bfc6577ae768725|
2013-08-22   09:46:58|install|libreoffice-icon-theme-hicontrast|4.1.0.4-3.1|noarch||openSUSE:Factory|be727de03f081c545947c4457e122be919c46c1bbe0bcae0f093946e180f949c|
2013-08-22   09:46:59|install|python-keyring|1.6-1.2|noarch||openSUSE:Factory|28df72aab16e500af14f95e3bbaea423021e354dd21d7d92af3d7c7e93a2e48b|
2013-08-22   09:47:00|install|update-test-affects-package-manager|0-19.13|noarch||openSUSE:Factory|982b4c2684e4ca56adb69890667b0ae2adb8dfcb765975eac6937ea1340ae474|
2013-08-22   09:47:00|install|update-test-interactive|0-19.13|noarch||openSUSE:Factory|163a2286aa22aea70a011e1bb46be351862c2f6fde44f0573c793bfefe5c65af|
2013-08-22   09:47:00|install|update-test-optional|0-19.13|noarch||openSUSE:Factory|74960c66453619201249feef0da5fb4acd55a155589a0d4392a9beea34935e89|
2013-08-22   09:47:00|install|update-test-reboot-needed|0-19.13|noarch||openSUSE:Factory|c13d12e021008b2ae908ec69e84defdde37252c6749802c824211f7284c4969d|
2013-08-22   09:47:00|install|update-test-security|0-19.13|noarch||openSUSE:Factory|c46bf511f932fe69a432d6fcc04b69deb64d908e187e34a99cbd51b3d188f101|
2013-08-22   09:47:00|install|update-test-trival|0-19.13|noarch||openSUSE:Factory|d380f75d6118af06d5adb9bd121413e6d394f16926828a199dc4ff78f18ec53d|
2013-08-22   09:47:01|install|libpyglib-gi-2_0-python2-0|3.9.90-1.1|x86_64||openSUSE:Factory|6a4d7d3ec7e4892216640d65a33b3ce27dc6a4df22aa992ba3deb3fec78e9fd3|
2013-08-22   09:47:01|install|patterns-openSUSE-update_test|13.1-10.2|x86_64||openSUSE:Factory|3d68d4aa7573d30f6ec9c772be947f91cd2d8e5ce7f7c78c124a19892bad4c3a|
2013-08-22   09:47:02|install|python-gobject|3.9.90-1.1|x86_64||openSUSE:Factory|ad417c03dccb0fe07efa73942d215eb529f7fee107aa23323dadf6c736f37e32|
2013-08-22   09:47:02|install|python-gobject-cairo|3.9.90-1.1|x86_64||openSUSE:Factory|f2f67740a0656a81f86b9834aaf963e648258cc2d294617f22d3e15d20391acf|
2013-08-22   09:47:02|install|aaa_base-malloccheck|12.3-14.8.1|x86_64||repo-update|300dbb501cb03d931718aff528406ebf65bcc6482762fe4bf40a2d9cd653f2a1|



No, not by default. Just type “libhan” without the asterisk and all packages containing “libhan” will be shown.

Or, select “Use Wild Cards” under “Search Mode”, then the asterisk would work:
http://wstaw.org/m/2013/08/22/yast_search.png

Oh and:

Those are 32bit packages. They won’t help you much on a 64bit system normally.

Also you seem to have the 12.3 AND Factory repos added. Remove Factory (in YaST->Software Repositories)!!! Otherwise your system WILL break sooner or later…
Please show the output of:

zypper lr -d

for further advise.

I found this site which I downloaded but did not install yet.

What say you ?

Index of /repositories/home:/swyear/openSUSE_12.3/x86_64

I think it wants to use something other than yast to install it.

I have no idea how the factory repos got there but they are gone now.

Re the wild card info:
I have the same 3 entries with libhangul1 and libhangul1-32 bit being checked.

What have you downloaded from there? I don’t see libhangul in there.

I think it wants to use something other than yast to install it.

Probably Apper. You can right-click on the package and select “Open With”->“Install/Remove Software” and it should install it with YaST.

I have no idea how the factory repos got there but they are gone now.

Right, but according to your history file, you already installed some packages from Factory, like libreoffice f.e.
You maybe should do a “zypper dup” to switch all packages back to the 12.3 versions, but better show your repo list first to be on the safe side (“zypper lr -d”).

And some more remarks:

  • Uninstall “aaa_base-malloccheck”, you don’t want that. From the package’s description:

This package sets environment variables that enable strictermalloc checks to catch potential heap corruptions. It’s not
installed by default as it may degrade performance.

  • Uninstall all those update-test packages (type “update-test” in YaST’s search field to list them)

  • “ibus-hangul” is a 32bit package. Install the 64bit version: “sudo zypper in -f ibus-hangul”

Re the wild card info:
I have the same 3 entries with libhangul1 and libhangul1-32 bit being checked.

So you have it installed. But libhangul1 alone won’t help. It’s just used by other packages. (“ibus-hangul” f.e., but as I said the 32bit version of this won’t help you much either; install the 64bit version…)

Which is very strange.

I have a rather clean 12.3 here (except Packman nothing added) and when I type hangul in the search address, I get eleven (11) packages offed with the text hangul either in the package name or in the description. All from the OSS repo. One of them being libhangul1. You need no wild card things there, it simply search for the characters hangul (case independent in Name, Keywords or Summary. Exactly as YaST tells you there).

So imho you have screwed up something. And it seems that wolfi323 already pointed yyou to some strange things. You better repair that first before you try again.

This is the PC where I am trying to get Korean to work,

linux-ntwr:~ # zypper lr -d
# | Alias                     |  Name                               | Enabled | Refresh | Priority |  Type   | URI                                                              | Service
--+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
1  | openSUSE:Factory          | openSUSE:Factory                   |  Yes     | Yes     |   99     | yast2  |  http://download.opensuse.org/factory/repo/oss/                  |        
2  | repo-debug                | openSUSE-12.3-Debug                |  No      | Yes     |   99     | NONE   |  http://download.opensuse.org/debug/distribution/12.3/repo/oss/  |        
3  | repo-debug-update         | openSUSE-12.3-Update-Debug         |  No      | Yes     |   99     | NONE   |  http://download.opensuse.org/debug/update/12.3/                 |        
4  | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss |  No      | Yes     |   99     | NONE   |  http://download.opensuse.org/debug/update/12.3-non-oss/         |        
5  | repo-non-oss              | openSUSE-12.3-Non-Oss              |  Yes     | Yes     |   99     | yast2  |  http://download.opensuse.org/distribution/12.3/repo/non-oss/    |        
6  | repo-oss                  | openSUSE-12.3-Oss                  |  Yes     | Yes     |   99     | yast2  |  http://download.opensuse.org/distribution/12.3/repo/oss/        |        
7  | repo-source               | openSUSE-12.3-Source               |  No      | Yes     |   99     | NONE   |  http://download.opensuse.org/source/distribution/12.3/repo/oss/ |        
8  | repo-update               | openSUSE-12.3-Update               |  Yes     | Yes     |   99     | rpm-md |  http://download.opensuse.org/update/12.3/                       |        
9  | repo-update-non-oss       | openSUSE-12.3-Update-Non-Oss       |  Yes     | Yes     |   99     | rpm-md |  http://download.opensuse.org/update/12.3-non-oss/               |        
linux-ntwr:~ #

There you have the Factory repo, remove that:

sudo zypper rr openSUSE:Factory

Otherwise the system WILL be switched to Factory, which is where the next openSUSE version (13.1) is developed. That’s not even Beta yet…
Or worse, you will get a mixture between 12.3 and Factory, which is even more unstable.

Then you’re safe to do “sudo zypper dup” to switch all your packages back to the 12.3 versions.

And remove those things I said. (“update-test-*” and “aaa_base-malloccheck”)

Well, it happened. I got a partial install of 13.1 and it locked up tight.
I didn’t see your comments about removing the factory stuff.

Please be patient with me, and luckily this is a brand new install with only a few modifications.
I am assuming that I will have to go back and reinstall 12.3 from the live cd ?

Right ???