Kontact Mail not recognising entries in the Contact file

I just started using Kontact and have imported all my contact details from Thunderbird. This worked OK, but I find that when I start a new email and begin to type the recipient’s name, the email address is not automatically pulled from the contact list as I would expect.

I also noticed that there doesn’t appear to be a ‘Send Email’ option in the Contact screen once an entry has been selected.

Kmail seems to be collecting email addresses from any emails I send, and if I start typing one of these, then it does auto-complete.

Have I missed a setting somewhere, or is there some other problem?

Since my original post, I’ve been digging around and came acroos several posts on other forums which reported the same problem. The proposed solution is shown in the KAddressBook 4.4 UserBase notes (KAddressBook 4.4 - KDE UserBase). This says,

“…your distribution may have already done this for you, but check SystemSettings > Advanced tab > KDE Resources. Make sure that the resources listed there are enabled, then use the ‘Set as Standard’ button on ‘akonadi-resource Personal’. This will make the Personal Contacts addressbook available to KMail.”

I’ve been trying to find the SystemsSettings > Advanced Tab > KDE Resources mentioned, but with no success. All I can see that looks remotely connected to the issue is if I go into System Settings > Personal Information, which has an entry for the default address book, but doesn’t seem to offer any opportunity to change it.

Am I looking in the wrong place?

Don’t seem to be getting any answers to this one. Can anyone tell me where I find the setting to make the Personal Contacts address book the default for Kmail?

As far as I can see, this is a bug in KMail; you may be able to get an answer from Office & Productivity • KDE Community Forums

Let’s check a couple of things: when you open KAddressbook, do you see all your contacts listed? Do you have an “address book” entry on the left pane? Next: from KMail, if you go to Tools - Address Book, do you see the same contact list?

If I open KAddressbook (clicking the ‘Contacts’ icon on the left of the screen) then I see all of my contacts listed in an address book named ‘Personal Contacts’. If I go back to the ‘Mail’ page and click on Tools in the top menu, I get no Address Book option. All that is available is, Certificate Manager, GnuPG Log Viewer, Edit ‘Out Of Office’ Replies, Filter Log Viewer, Account Wizard, Anti Spam Wizard and Anti Virus Wizard.

That’s bizarre. What version of KDE are you running? Do you see anything listed if you go to Configure Desktop - Personal Information, and then pick Contacts from the dropdown list? If so, click on Edit and make sure that the “Contacts” checkbox is enabled. You will probably also have to click the “Use as Standard” button on the main config page for the Contacts option.

I’m using Platform Version 4.6.00 (4.6.0) “release 6”.

If I go into System Settings - Personal Information and select Contacts from the drop-down, I see just one entry, named Default Address Book. The checkbox for this is ticked. The path for the Contacts file is shown as home/dave/kde4/share/apps/kabc/std.vcf, which I suspect may be the problem. From reading other threads, it appears that Kmail may be using a different path, but I can find no way to check this. The only reference to address auto-completion in the Kmail settings is a checkbox named ‘Use recent addresses for autocompletion’, which I have selected and which works OK.

I seem to have cracked it at last, thanks to a suggestion from someone on the KDE forums.

The problem was that Kmail does not automatically pick up a link to the Personal Contacts address book. To get it to do this I needed to go to System Settings > Personal Information.

From this screen select ‘Contacts’ in the Resources drop-down. It is here that you need to add your akondai address book resource.

Helpfully, the ‘Add’ button is not labelled, it is the one just above the ‘Remove’ button. Click this and select ‘Akonadi Address Books’ which is first in the list on my system.

Once I added this and ran through the short set-up process, my contact e-mail addresses started to auto-complete when I composed new messages.

This was a pretty obscure issue and not one which a former Gnome like myself would have found easily. Why Kmail does not make the association automatically during installation/set-up is a mystery. Something the developers might want to consider.

Many thanks for all the help. Much appreciated.

Are you running a non-default theme for KDE? I’ve attached an image and the “Add” button is perfectly labeled in my case…?

ImageBam - Fast, Free Image Hosting and Photo Sharing

I’m using Oxygen as an icon theme. Other than that, everything is whatever the default was when I installed it.

Can you send a screenshot - this I have to see to believe :wink:

Screenshot attached.


I have had this problem with one user but not the other; on following the links that Gewitty provided I found that the Default Address Book was assigned to stdvcf in .kde4; however, in one user Akonadi had stored the addresses in .local~contacts; in the other they were still in stdvcf. So I solved the problem by going into System settings>Personal information and changing the assignment of the Default Address Book to .local~contacts. Now everything works fine in both users even though the setups are quite different.

My hunch is that when I installed openSUSE at some time in the past Akonadi made this change to the first user but, when I added in the second user after install, it did not do anything.

Wow - I see it, I believe it, but I can’t explain it. Can you create a bug on the KDE bug list: https://bugs.kde.org/?

Reported as a bug.