Kontact group scheduling acting unusual, Suse 12.1

The group scheduling feature of Kontact calendar is not working as one would expect. Here are some of the issues:

  1. There doesn’t appear to be a way to reset the default meeting organizer. When I create an event and select the attendees tab, the Meeting Organizer points to the wrong person. The correct person can be selected by pulling down on the meeting organizer name field. However, there does not appear to be a method for resetting the default meeting organizer. I’ve tried changing the default identity on Settings → mail ----> identities. I’ve tried changing the default identity at Settings ----> calendar -----> Group Scheduling. And, I’ve tried setting configure desktop —> account settings. I’ve also even deleted the wrong person from the group scheduling settings. No matter what, the wrong person appears.

  2. The email transport used for group scheduling fails. The mail transport is incorrectly parsing the user name and email address of the meeting organizer and attendees, causing an email delivery failure from either cause.
    Example one: in Settings —> Identities —> modify (or add) a form pops up requesting “Your name”, Organization and “email address”. Lets say “Your name” is username1 and the “email address” is username1@url. Now, lets send an invitation to a username2@url. If “Your name” is set to username1, the email invitation fails. The failure is that the email transport is attempting to send an email to <“username1” <username1@url>>. The email server parses this and fails, indicating that it is expecting an “@” or a “.” after the first username1. Most likely, the email transport should be sending “username1” <username1@url>.

Example two: remove username1 from the “your name” in the identities section. Resend the invitation. The email invitation also fails. This time, it gets past the meeting organizer, but fails on the attendee. The email server gives a similar failure message because it is attempting to email the invite to <“username2” <username2@url>>.

Are these problems solvable, or should I report a bug?

Any help would be appreciated.