Kontact Fails to Start

After upgrading to Plasma 6.0.3, Kontact fails to start. It was working fine in 6.0.2. In the command line, after typing “Kontact,” the following message appears:

Path override failed for key base::DIR_APP_DICTIONARIES and path ‘/usr/bin/qtwebengine_dictionaries’
Path override failed for key base::DIR_APP_DICTIONARIES and path ‘/usr/libexec/qt6/qtwebengine_dictionaries’
Path override failed for key base::DIR_APP_DICTIONARIES and path ‘/usr/libexec/qt6/qtwebengine_dictionaries’

Hello and welcome to the openSUSE forums.

We are always curious on HOW things are done. After all it might have gone wrong already during that “upgrading”.

And please, when you want to show what happens on the command line (always a good thing), then please copy/paste all that belongs to it: the line with the command (so no description like “typing …” needed), all output up to and including the next prompt (to show that is all there is). And post it using the </> button (Preformatted text) from the tool bar of the post editor.

Than you!

Please find below the output when I type “kontact” in Konsole:

Path override failed for key base::DIR_APP_DICTIONARIES and path ‘/usr/bin/qtwebengine_dictionaries’
Path override failed for key base::DIR_APP_DICTIONARIES and path ‘/usr/libexec/qt6/qtwebengine_dictionaries’
Path override failed for key base::DIR_APP_DICTIONARIES and path ‘/usr/libexec/qt6/qtwebengine_dictionaries’
KCrash: Application ‘kontact’ crashing… crashRecursionCounter = 2
Segmentation fault (core dumped)

I think your system is inconsistent - you’re missing packages.

When I start kontact via the console, I get the same error messages. Nevertheless, kontact starts.

kontact
Path override failed for key base::DIR_APP_DICTIONARIES and path '/usr/bin/qtwebengine_dictionaries'
Path override failed for key base::DIR_APP_DICTIONARIES and path '/usr/libexec/qt6/qtwebengine_dictionaries'
Path override failed for key base::DIR_APP_DICTIONARIES and path '/usr/libexec/qt6/qtwebengine_dictionaries'
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...
/usr/bin/mysqlcheck: Deprecated program name. It will be removed in a future release, use '/usr/bin/mariadb-check' instead
akonadi.collectionattributetable                   OK
akonadi.collectionmimetyperelation                 OK
akonadi.collectionpimitemrelation                  OK
akonadi.collectiontable              
...

Great news!

After upgrading to Snapshot 20240425 in Tumbleweed, Kontact starts just fine. I tested it three times, and each time, it opened fine.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.