Konsole Transparency background with picture, OpenSUSE 13.1 KDE


I may be beating a horse, but I haven’t found a clear answer. Last year when I installed OpenSUSE 13.1 KDE, I couldn’t have the Konsole background to be transparent if I put an image there. Eventually I found a solution and I apparently didn’t share it with anyone.

Today, I re-installed OpenSUSE 13.1 on a new laptop, I wish to stay with 13.1 with evergreen, I found 13.2 glitchy here and there. I never had this issue with 13.2, so a lot of people may have overlooked.

If it’s any help, I think the solution had something to do with disabling a certain desktop effect.

Thank you for your time.

Try opening Konsole and then: Settings > Edit Current Profile > click Apperance tab > Edit > then set your “Background transparency” and “Background image” and then click apply

Thanks, but there were reported bugs on what I’m dealing with and I do recall finding a solution to it.

Basically I have 2 options without the fix:

  1. Translucent background solid colour

  2. Opaque background picture.

What I want and am used to is:
3. Translucent background image.

  1. is a given in OpenSUSE 13.2 environment, but on 13.1 environment, I recall having to do something to fix it, installing konsole 5 didn’t help btw.

Ah, I see.

FWIW, it appears (from rather extremely limited testing) that 3 is a little buggy in TW … I do normally use konsole translucency, but with no background image (i.e. just the default black colour). So after I read your reply, I tested it out myself i.e. I set an image … It worked (translucent background image), but the one I had randomly selected wasn’t a good image to use with the default font colour. So I then tried changing to a more appropriate image but the terminal locked up (rest of desktop was still completely useable). I could actually launch other konsole terminals too, but they too were locked up, and so had to do a killall of it via krunner (alt-f2). After killing it, I found konsole was again functional when I reopened it and was able to then change the background image to a more appropriate one…Anyway, after that, I turned off the background image and did not test any further (as to whether the bugginess I had encountered was a “one and done” case, or would have reared itself again) …

Well… Abandon ship…

After 10+ hrs of installation/customization, one faithful update destroyed my KDE. Going back to 13.2 now.