Konsole line-wrap problem on Leap 15.2

A new guy needs help!

Not sure if this is the right place to post, but let’s give it a try…

Different terminal-emulators on my Leap 15.2 box (KDE/Plasma 5.18.6, Nvidia video) all show this same problem (see below). I’m normally running ‘Konsole’ under KDE, but have tried several other ‘terminals’, including XTERM - ALL show the same behavior.

Problem: In typing in a long command, when the input line length reaches about 3/4 of the terminal width (not the end), the line ‘wraps’ … i.e. the cursor wraps back to the start of the line, with NO line-feed. Now, as I type more characters, they over-write the beginning part of the line. Makes it really hard to see the entire command that I’m typing!

I’m thinking this must be an X setting somewhere, since it happens in different terminal emulators. Regardless if that’s true or not, I have no idea where to look or what to look for!

Does anyone know how to fix this? (I’ve tried several possible solutions, including ‘-aw’ and the escape-character sequence to turn off wrapping, all to no avail.)

Thanx in advance for any suggestions!


Output of

echo $TERM
stty -a

would be interesting.

Thanks, arvidjaar!

Here they are:

**rkruse@SUSE**:**~****$** echo $TERM

**rkruse@SUSE**:**~****$** stty -a
speed 38400 baud; rows 30; columns 100; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>;
swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; discard = ^O
min = 1; time = 0;
-parenb -parodd -cmspar cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon ixoff -iuclc -ixany -imaxbel
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke -flusho

(Reasonable; my Konsole is set to 100 x 30.)

Just for grins, I downloaded the live version of LEAP 15.3 - its Konsole does NOT do this. Maybe my problem is caused by the Nvidia driver? When I get a chance I’ll try unloading that.


Me again… I’m the O.P…

SOLVED! …but in a totally unexpected way…

In making a color BASH prompt, I was using wrong color-codes.

For example, in .bashrc, I was defining red=’\e[0;31m’ and then using “red” (no quotes) in my PS1 string. IOW, I had neglected to include the enclosing [ and ] characters.

I changed it to define red=’\e[0;31m]’ (likewise for other colors) and presto… my line-wrap problem went away! (I got this hint from lots of Googling.)

How this got by without throwing some kind of error, I’ll never know.

So the moral of this story is - If anyone else here is having terminal line-wrap issues, double-check your color-prompt codes!

-Richard (now a happy commdnd-line user)