Konsole highlight text not visible on 15.4

hello.

here screen shot on 15.4

https://paste.opensuse.org/61807602

here screenshot on 15.3

https://paste.opensuse.org/1591106

Is it possible to have the same on 15.4.

Any help is welcome.

Try a different colour scheme?

Settings -> Manage Profiles -> (Select Profile - or if using “Default [Read-only]” create a new profile) -> Edit - Appearance

From there you can choose an appropriate colour scheme, or customise an existing scheme, to suit your requirements.

https://paste.opensuse.org/view/raw/346897dd

Where do you see to change highlight selected text

Appearance -> Miscellaneous -> Always invert the colors of selected text

@jcdole

… and if you’re interested in the rationale behind the changes made in konsole to the way highlight colours are chosen see:

https://bugs.kde.org/show_bug.cgi?id=435309
https://invent.kde.org/utilities/konsole/-/commit/38208f94cd371ab2ebb66fe008441759b487f1e6

Please look at my example.

from your coments : “435309 – 3b06b6f22 makes selection near invisible with some foreground/background color combinations
reported since “Reported: 2021-04-03 11:14 UTC by Duncan”

Bug still here.

You sure?

What konsole colour scheme are you using?

Looks OK to me using default unmodified “Breeze” with “Always invert the colors of selected text.” enabled. The selected text has all colours inverted as in your first (15.3) screenshot - or am I missing something here?:\

https://paste.opensuse.org/view/raw/cc607261

Operating System: openSUSE Leap 15.4
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.14.21-150400.24.18-default (64-bit)
Graphics Platform: X11

I also had the same annoyance regarding highlighted text being virtually indestinguishable in a konsole terminal window. Clicking under miscellaneous tab to invert highlighted text solved the problem for me. I tested on a half dozen color schemes and all distinguished the highlighted text well.

tom kosvic

Breeze

https://paste.opensuse.org/87946187

https://paste.opensuse.org/58997145

Well it seems to be working for other people… as seen in my screenshot in post #8, and also confirmed by @tckosvic in post #9

This https://paste.opensuse.org/view/raw/c8cbdfed is using the “White on Black” colour scheme that you show in your second screenshot of post #10 (have you actually selected any text in that screenshot)…

You have enabled “Always invert the colors of selected text.”?

Try with a new user and if you’re able to replicate the issue then I would suggest you file a bug report against konsole over at KDE https://bugs.kde.org/

Ok.
That works.
thanks