Konqueror - nur eingeschränkt nutzbar?

Vielleicht ist das Thema hier besser aufgehoben … Konqueror - nur eingeschr

Das hier wäre der Punkt Nr. 3) Konqueror bringt auf sehr vielen Seiten eine “JavaScript Fehlermeldung” mit der Aufforderung, den Fehler zu debuggen (ich hoffe, ich drücke mich richtig aus). Das mit den Entkäferungen nervt aber … Woran liegt dieses Verhalten?

############
Hier (Konqueror › Wiki › ubuntuusers.de) habe ich zwischendurch eine Notiz zum Thema S k r i p t e gefunden:

Konqueror bietet zwar die Möglichkeit, die Verwendung von JavaScript einzuschränken, jedoch nicht so komfortabel wie mit der von Mozilla Firefox bekannten NoScript Erweiterung. Die Einstellungen zu JavaScript findet man über “Einstellungen -> Konqueror einrichten -> Java & JavaScript” im Reiter JavaScript. Hier kann man einstellen, ob JavaScript global verwendet werden soll oder es können seitenspezifische Regeln festgelegt werden. So könnte man JavaScript global deaktivieren und nur für einige Seiten erlauben. Eine solche Einstellung ist jedoch nur bedingt zu empfehlen, da moderne Ajax-Anwendungen ohne JavaScript nicht funktionieren.

Konqueror bietet auch einige Einstellungen, um zu regeln, wie auf Ereignisse wie das Öffnen neuer Fenster in JavaScript reagiert werden soll. Hierüber lassen sich einige unangenehme Verhaltensweisen von Webseiten ausschalten.

############
(noch mal: Konqueror - nur eingeschr) Hi Leute,

ich muss jetzt einfach mal die Frage ins Netz stellen, weil mein Bedürfnis nach Aufklärung allein durch die Angaben im Hilfezentrum nicht befriedigt wird.

Ich nutze schon seit einiger Zeit openSuSE und bin sehr zufrieden! Bisher habe ich als Browser immer Firefox benutzt - von diesem bin ich nach wie vor überzeugt. Nur bin ich neulich auf die Vorzüge des Konqueror aufmerksam geworden: Er vereinigt so viele Funktionen, und auch andere Programme der KDE-Oberfläche sind hervorragend dort integriert. Nicht zuletzt lässt er sich als Dateimanager nutzen. Auch Werbeblocker lassen sich - ähnlich wie beim Feuerfuchs - einfach einbinden.

Meine beiden Anfragen:

  1. Für Firefox gibt es vorgefertigte Skript-Blocker wie NoScript. Ist in/für Konqueror ein Äquivalent vorhanden?

  2. Ich nutze öfter Funktionen wie das “MediaCenter” unter meiner gmx-Mail oder den “SmartDrive” unter web.de und wie sie alle heißen. Es gelingt mir nicht, die Anwendung unter Konqueror zum Laufen zu kriegen. Hier stößt er an seine Grenzen … Ist das notwendig so oder lässt sich das beheben? (Ich habe Oracle/Sun Java installiert.)

Danke für Eure Auskünfte :slight_smile:

##########

  • Notebook: Lenovo G530 4446-25G — Dualboot: (1) Windows 7 32bit; (2) openSUSE 11.4 (i586), Kernel: Linux 2.6.37.6-0.7-default i686, KDE 4.6.00 (4.6.0) “release 6”

Ergänzungen

Im Augenblick teste ich ab und an, wenn ich entspannt am Rechner sitzen kann, Konqueror als Webbrowser. Leider gibt es andauernd Debug-Meldungen.

Ein Grund für weitere Fehlermeldungen scheint die Inkompatibilität mit der aktuellen Flash-Player-Version zu sein - sobald ‘nspluginviewer’ gefordert ist, bringt er Fehlermeldungen (das nötige Paket sei nicht installiert). Die Inkompatibilität ist meine Deutung nach: LINUX • Thema anzeigen - [gelöst] Konqueror mit Adobe Flash Plugin 9.0.115.0

Liege ich hier richtig?

Eben habe ich Konqueror aufgerufen, und die erste Seite - youtube -, die ich aufrief, brachte schon den ersten Fehler. Als ich dann den Entwicklern den Bericht schicken will, erscheint wieder die bekannte Meldung:

Für die folgenden Anwendungen und Bibliotheken fehlen die Pakete mit den Debug-Informationen:
- /usr/bin/nspluginviewer
- /usr/lib/browser-plugins/libflashplayer.so

Wie heißen die Pakete? In welchem Repo befinden sie sich?

Am 2011-09-17 10:26, schrieb ThJJackson:
>
> Eben habe ich Konqueror aufgerufen, und die erste Seite - youtube -, die
> ich aufrief, brachte schon den ersten Fehler. Als ich dann den
> Entwicklern den Bericht schicken will, erscheint wieder die bekannte
> Meldung:
>
>
> Code:
> --------------------
> Für die folgenden Anwendungen und Bibliotheken fehlen die Pakete mit den Debug-Informationen:
> - /usr/bin/nspluginviewer
> - /usr/lib/browser-plugins/libflashplayer.so
> --------------------
>
>
> Wie heißen die Pakete? In welchem Repo befinden sie sich?
>

wahrscheinlich hast du das debug repo schon aktiviert, und die
Suchfunktion des SW-Installers spuckt nichts aus? Kein Wunder.
Wahrscheinlich gibt es auch gar keine debug-info für diese
Pakete, weil proprietär.
Vielleicht kannst du dein Problem an der Wurzel angehen: Schmeiß’
Adobe raus und installiere dir eine der freien Alternativen
swfdec oder gnash. Geht es dann? Und hast du mal andere Browser
probiert, z.b. firefox?

Christoph


email:
nurfuerspam → gmx
de → net