Konqueror loading webpages in firefox (rather than Konqueror)

I have just done a clean install from the latest ISO 20092021,using Plasma kde, and have an issue with Konqueror. When I start Konqueror and load a website it opens in Firefox (rather than Konqueror). This happens whether I load a website from a bookmark or from a google search.

Is anyone else having the same problem.

It is not complete clear to me what you exactly do.

When I open Konqueror and put an URL in the address bar, the web page opens in Konqueror. When I then click on a link in that page, it again opens in Konqueror. All as I expected.

Thanks for responding hcvv

That is my issue:

When I open Konqueror and put an URL in the address bar, the web page opens in firefox (instead of Konqueror)

Have you updated to the latest tumbleweed?

I am using Konqueror 21.08.1-1.2

I asked because “load a webpage” wasn’t clear enough to me (it was put there as if it could be something complete without connection to the, by incident, also running Konqueror), the more because what you see is indeed very strange.

And no, I run Leap 15.2. But getting a clear problem description is one of the things that will help everybody.

Now resolved. I opened System Settings / Applications / Default Applications and konqueror was set to default web browser. Changed the default to Falkon and then changed it back to Konqueror and all is well.

I have the same issue in Tumbleweed. When I click on the home button or type anything in the address bar, it opens a tab in Nightly(my default browser).

Operating System: openSUSE Tumbleweed 20210923
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.5-1-default (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Glad it is not just my system (sorry).

To fix the issue:

Open - System Settings > Applications > Default Applications and change the default web browser to something else. Then change it to Konqueror

Another change which is worth making is in the Konqueror settings. In the general settings, under Tabbed Browsing, add a tick to entries 2 and 3. This stops Konqueror from opening a new window for each website. This issue seems to be from Kde Frameworks 5.86 - as the same thing happens with Kde Neon.

I’m good, going to leave it on Nightly. I only open Konqueror because Waterfox stop working after the big update.