Konqueror file associations

I added the avi format to my konqueror video file associations. Then I tried to set kaffeine/KDE3 as the primary application instead of “enqueue in smplayer”. It would not set. It would not remove. Even if I did it as root.

Any suggestions?

Do you mean right click an .avi
then the config/spanner icon
then move up and down apps in the list?

That was quick!

I mean konqueror > Settings > Configure konqueror > File management > File associations > Video > Avi (added by me) > Filename patterns (*.avi) > Application preference order…

which lists…

Enqueue in Smplayer
Vlc media player

when I try to move Kaffeine/KDE3 up the list it doesn’t, and when I try to delete Enqueue in Smplayer, it doesn’t.

You can not do this as root. It is a setting of that particular user you are loged in as (and you will not be loged in as root).

Well I tried it both as user, and as root. I logged out as user and logged in as root. Neither worked.

What I try to explain is:

  1. it is useless because it is a per user setting (in the users home directory somewhere in $HOME/.kde4); Thus as it works for root, it does not work for ionmich (or what username you use on your system) or for any other user you might have on the system; and if you manage (as we hope) to let it work as you want for ionmich, nothing changed for any other user on the system.

  2. of course that you NEVER SHOULD LOG IN AS ROOT.

Either I am misunderstanding you, or you are misunderstanding me, or possibly both.

  1. I logged in as ionmich and tried to change the Konqueror file association application for avi from “Enqueue in Smplayer” to “Kaffeine/KDE3” (as a matter of fact I tried to change it to “vlc” as well). It would not change and reverted to “Enqueue in Smplayer”. I then logged out.

  2. I logged in as root and tried it again. Same result. I do understand that if it had changed when logged in as root, it would only apply when logged in as root. I was merely confirming that it was not a permission issue.

  3. I understand the danger involved when logged in as root HOWEVER there are situations when I want to test a script needing root privileges.

The search to resolve this problem continues.

Either I am misunderstanding you, or you are misunderstanding me, or possibly both.

It’s a simple as this.

  1. of course that you NEVER SHOULD LOG IN AS ROOT.
    You just said:
  1. I logged in as root and tried it again.

In such cases (when you suspect it being some broken configuration of the user), one simply creates a new user (which is easy to delete after the test, leaving no traces).

One NEVER LOGS IN AS ROOT. How would you undo everything that is done to your system (mainly in /root) doing this? It is near to impossible to revert to the status before you did log in as root into the GUI. That is apart from all the obvious, and for many people less obvious, dangers when being loged in as root.

In any case, from my point of view I have stressed the stupidness of logging in as root in the GUI enough. Either you got the message or not.

We better turn back to your original problem. Did you try caf4926’s suggestion in post#2? And what about the Configuration item from the main menu and then the Advanced tab en then File Associations (as I have a non english KDE before me, the real english term might differ, but I hope you will find what I mean).

I will use your suggestion of creating a new user in future. It sounds quite logical.

Yes I did try the other method. I went to Application Launcher Menu > Personal Settings (Configure Desktop) > Advanced > File Associations > Video > Avi and tried to change the application order. It did not change.

Going back to the original problem is now going to be difficult. In the process of trying to resolve a different problem (that of “sparklies” in some video players) I ended up re-installing the O.S. This time I only installed kaffeine, so it is the only application in the file associations. That solves my problem for the time being. I will check again later and report my progress.

Thanks for the ongoing help.

That is a nice solution. :wink:

Back to this a year later.

Now the File Associations for Audio > mp3 are set to Clementine then VLC, but Konqueror still insists on using Amarok to play mp3 files.

Does anyone know where the appropriate config file for File Associations resides?


Just like this works for me, but I use amarok



Yes I did that so that Clementine shows at the top and VLC second and nothing else. But mp3 files still start in Amarok. Do me a favor, and change the order so that VLC is first and see if Konqueror plays mp3’s with VLC.


Did that and Yes it plays in VLC

But I’m gong to a mp3 file, right click > properties > then click the config spanner
As shown in my image, or do you need a video?

That did the trick. You know you gave me the same answer long ago, almost a year, but I never saw the config spanner. Thank you for being so patient.

We aim to please. Well done!