Kodi crash on startup after upgrading from Leap 42.3 to 15

Hi,

I just updated my system from OpenSuSE Leap 42.3 to 15. All went fine and everyting is working as it should, except for kodi. No matter what I try, on every start I get this error message:

/usr/lib64/kodi/kodi.bin: symbol lookup error: /usr/lib64/kodi/kodi.bin: undefined symbol: _ZN13TiXmlDocument8StreamInEPSiPSs

Any suggestions on how to fix this are greatly appreciated.

Louis

Ah, never mind. Fixed it. It seems that the Packman package for SuSE is missing some dependencies. I tried to install kodi-18.0-0.33.git4c0a23e.fc29.x86_64.rpm from here: https://rpmfind.net/linux/rpm2html/search.php?query=kodi (SourceForge version).

That is missing 1 dependency that SuSE does not provide, but if you continue anyway, it will install some more dependencies. This version of kodi will not start either, but if you then reinstall the Packman version it’s working again.