"knotify closed unexpectedly" when using dolphin or konqueror Delete item

I have delete enabled in right button menu in konqueror and dolphin. Since some days ago (and I don’t remember when nor if I did something) when i try to delete one or more items i get a error message “knotify closed unexpectedl” at the same time that the popup appears asking for confirmation to delete the item.
I can close the knotify error message and I can continue deleting the item “as if nothing had happened”, but i would like to wnok why it happens.
Here is the debug log of knotify

 Application: KNotify (knotify4), signal: Segmentation fault
 Using host libthread_db library "/lib64/libthread_db.so.1".
 [Current thread is 1 (Thread 0x7ff5bf905800 (LWP 16862))]

 Thread 4 (Thread 0x7ff5a8979700 (LWP 16865)):
 #0  0x00007ff5bcafec5d in poll () at /lib64/libc.so.6

 #1  0x00007ff5ba168be4 in  () at /usr/lib64/libglib-2.0.so.0
 #2  0x00007ff5ba168f0a in g_main_loop_run () at /usr/lib64/libglib-2.0.so.0
 #3  0x00007ff5b1897946 in  () at /usr/lib64/libgio-2.0.so.0
 #4  0x00007ff5ba18db85 in  () at /usr/lib64/libglib-2.0.so.0
 #5  0x00007ff5bab850a4 in start_thread () at /lib64/libpthread.so.0

 #6  0x00007ff5bcb0708d in clone () at /lib64/libc.so.6

 Thread 3 (Thread 0x7ff5a3fff700 (LWP 16866)):
 #0  0x00007ff5bcafad2d in read () at /lib64/libc.so.6

 #1  0x00007ff5af942f45 in  () at /usr/lib64/tls/libnvidia-tls.so.340.76
 #2  0x00007ff5ba1a9750 in  () at /usr/lib64/libglib-2.0.so.0
 #3  0x00007ff5ba168714 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
 #4  0x00007ff5ba168b7b in  () at /usr/lib64/libglib-2.0.so.0
 #5  0x00007ff5ba168cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
 #6  0x00007ff5ba168d29 in  () at /usr/lib64/libglib-2.0.so.0
 #7  0x00007ff5ba18db85 in  () at /usr/lib64/libglib-2.0.so.0
 #8  0x00007ff5bab850a4 in start_thread () at /lib64/libpthread.so.0
 #9  0x00007ff5bcb0708d in clone () at /lib64/libc.so.6

 Thread 2 (Thread 0x7ff58f865700 (LWP 16870)):
 #0  0x00007ff5bcafec5d in poll () at /lib64/libc.so.6
 #1  0x00007ff5ba168be4 in  () at /usr/lib64/libglib-2.0.so.0
 #2  0x00007ff5ba168cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
 #3  0x00007ff5bd2810de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
 #4  0x00007ff5bd252e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
 #5  0x00007ff5bd253165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
 #6  0x00007ff5bd1500bf in QThread::exec() () at /usr/lib64/libQtCore.so.4
 #7  0x00007ff5bd234783 in  () at /usr/lib64/libQtCore.so.4
 #8  0x00007ff5bd15279f in  () at /usr/lib64/libQtCore.so.4
 #9  0x00007ff5bab850a4 in start_thread () at /lib64/libpthread.so.0
 #10 0x00007ff5bcb0708d in clone () at /lib64/libc.so.6

 Thread 1 (Thread 0x7ff5bf905800 (LWP 16862)):
 [KCrash Handler]
 #5  0x00007ff5bcab1b8a in __strcmp_sse2_unaligned () at /lib64/libc.so.6
 #6  0x00007ff58c430fee in QMetaType::registerNormalizedType(QByteArray const&, void (*)(void*), void* (*)(void const*), void (*)(void*), void* (*)(void*, void const*), int, QFlags<QMetaType::TypeFlag>, QMetaObject const*) () at /usr/lib64/libQt5Core.so.5
 #7  0x00007ff58c930f57 in  () at /usr/lib64/libQt5Gui.so.5
 #8  0x00007ff5bf79c92a in call_init.part () at /lib64/ld-linux-x86-64.so.2
 #9  0x00007ff5bf79ca13 in _dl_init_internal () at /lib64/ld-linux-x86-64.so.2
 #10 0x00007ff5bf7a0b48 in dl_open_worker () at /lib64/ld-linux-x86-64.so.2
 #11 0x00007ff5bf79c7e4 in _dl_catch_error () at /lib64/ld-linux-x86-64.so.2
 #12 0x00007ff5bf7a033b in _dl_open () at /lib64/ld-linux-x86-64.so.2
 #13 0x00007ff5b82df02b in dlopen_doit () at /lib64/libdl.so.2
 #14 0x00007ff5bf79c7e4 in _dl_catch_error () at /lib64/ld-linux-x86-64.so.2
 #15 0x00007ff5b82df5dd in _dlerror_run () at /lib64/libdl.so.2
 #16 0x00007ff5b82df0c1 in dlopen@@GLIBC_2.2.5 () at /lib64/libdl.so.2
 #17 0x00007ff58e6da59f in  () at /usr/lib64/libvlccore.so.7
 #18 0x00007ff58e6c3d5d in  () at /usr/lib64/libvlccore.so.7
 #19 0x00007ff58e6c4057 in  () at /usr/lib64/libvlccore.so.7
 #20 0x00007ff58e6c42c9 in  () at /usr/lib64/libvlccore.so.7
 #21 0x00007ff58e6c4534 in  () at /usr/lib64/libvlccore.so.7
 #22 0x00007ff58e6c4a87 in  () at /usr/lib64/libvlccore.so.7
 #23 0x00007ff58e65c49d in libvlc_InternalInit () at /usr/lib64/libvlccore.so.7
 #24 0x00007ff58e42d623 in libvlc_new () at /usr/lib64/libvlc.so.5
 #25 0x00007ff58e95eec9 in  () at /usr/lib64/kde4/plugins/phonon_backend/phonon_vlc.so
 #26 0x00007ff58e944728 in  () at /usr/lib64/kde4/plugins/phonon_backend/phonon_vlc.so
 #27 0x00007ff58e9451eb in qt_plugin_instance () at /usr/lib64/kde4/plugins/phonon_backend/phonon_vlc.so
 #28 0x00007ff5bd238641 in QPluginLoader::instance() () at /usr/lib64/libQtCore.so.4
 #29 0x00007ff58ee5bf8b in  () at /usr/lib64/kde4/plugins/phonon_platform/kde.so
 #30 0x00007ff58ee5c773 in  () at /usr/lib64/kde4/plugins/phonon_platform/kde.so

 #31 0x00007ff5beef3c76 in  () at /usr/lib64/libphonon.so.4
 #32 0x00007ff5beef4317 in Phonon::Factory::backend(bool) () at /usr/lib64/libphonon.so.4
 #33 0x00007ff5beef48e3 in  () at /usr/lib64/libphonon.so.4
 #34 0x00007ff5beeec9b9 in  () at /usr/lib64/libphonon.so.4
 #35 0x00007ff5beeea896 in  () at /usr/lib64/libphonon.so.4
 #36 0x000000000040e771 in _start ()

I have reinstalled the package wich contains knotify (I don’t remember now which is, but I searched it with yast and forced a reinstallation), but it did not solve the problem.
I see the problem seem to star in /lib64/libc.so.6 so may be a libc6 problem?


Uninstall phonon-backend-vlc, this does not work at all with VLC 2.2, as it is built against VLC 2.1 (and it has other severe problems as well).

I see the problem seem to star in /lib64/libc.so.6 so may be a libc6 problem?

No. Actually it is a clash between Qt4 and Qt5 (loaded by VLC), but even without that crash it wouldn’t work.
Your phonon-backend-vlc uses the libvlccore7 from VLC 2.1, but you only have the plugins and codecs for 2.2 installed.

If you insist on using the VLC backend, you’d need to downgrade VLC to 2.1, but the version included in openSUSE 13.2 doesn’t come with restricted codecs.

OK solved. It may be there as a result of an upgrade of the OS from a previous version.


Well, phonon-backend-vlc is (still) part of the distribution. But it only works with the VLC version that’s also included in the distribution, not with later ones you might have installed from Packman or the VLC repo.
There’s not much that can be done about that, maybe Packman should provide phonon-backend-vlc built against their VLC. They did until a few months ago (unnecessarily, because 2.1.x was the latest version back then so the openSUSE phonon-backend-vlc worked with VLC from Packman anyway), but removed it for some reason.

On Tumbleweed this is no problem though, as it contains the latest VLC version anyway.

But as mentioned, phonon-backend-vlc has other problems as well (when PulseAudio is in use), e.g. it raises the volume to 100% whenever a notification sound is played. And it lacks features compared to the default gstreamer backend.

All in all you’re probably better off with the gstreamer backend, I suppose.