KNM says connected and activated, but won't go online!


new home network at uni is by sky, KNM says it’s connected wirelessly and shows signal strength and that the wlan0 is activated, but it won’t go online. even if i plug the laptop in via a LAN cable, it says connected but won’t go online. my flat mates who have windows can get online, so why can’t i :frowning:

half of me thinking it’s the router? but if windows can connect linux should be able to, really. no?


Have you tried disabling IPv6
Disable IPv6 - openSUSE Forums

What happens if you put in an IP rather than a URL


thanks for the quick reply, i have disabled IPv6, i will try and type in an IP address when i get back home. if i can’t connect still, my replies will be slow unfortunately because i have to come to the uni library for internet :frowning:

cheers again,


hi, tried typing in an ip address and says failed to connect! Could it be that suse 11.1doesnt like the router? Any more ideas? Thanks guys!

if it makes any difference, my ps3 has connected fine and the security is wpa-psk (tkip). Can knetworkmanager cope with this? Thanks

I use wpa/wpa2 Personal
Not sure about wpa-psk

On 10/25/2009 04:06 PM, caf4926 wrote:
> I use wpa/wpa2 Personal
> Not sure about wpa-psk

WPA-PSK IS WPA Personal. Yes, 11.1 NM can handle this.

You need to do the 3-step process in Comment #9 in These steps will decide if you have a
routing or a DNS problem.

Note: Your router/gateway address can be determined from the output of

/sbin/route -n

It should look like

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref
Use Iface U 2 0
0 wlan1 UG 0 0
0 wlan1

Note that my router is at

If step 1 fails, please post the outputs from



thanks for the reply guys, sorry it’s a slow reply, i’ve been very busy the last week. i will try those commands and get back. as said, it still won’t connect (though NM says it is) by ethernet cable. could it be a crap router which is not supported?


right guys, an update, and an interesting and annoying one! i came home this weekend to find my laptop wouldn’t even connect to my home network which it has done in the past. this makes me think that something like an update has caused the problem???

will get the results of the commands given above later.


me again,

i installed 11.2 64bit and now it connects fine :slight_smile:


Excellent news!