Knetworkmanager refuses to start

All of a sudden the Knetworkmanager icon disappeared from my panel and when I try to start it from a console I get the following output.

ion@linux-4cfs:~> knetworkmanager
terminate called after throwing an instance of ‘std::bad_alloc’
what(): std::bad_alloc
KCrash: Application ‘knetworkmanager’ crashing…
knetworkmanager(6762): Communication problem with “knetworkmanager” , it probably crashed.
Error message was: “org.freedesktop.DBus.Error.ServiceUnknown” : " “The name org.kde.knetworkmanager was not provided by any .service files” "

The only change I can associate with it is an online update last night.

Any help would be appreciated.


zypper lr -d

ion@linux-4cfs:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | packman | packman | Yes | Yes | 99 | rpm-md | Index of /pub/linux/misc/packman/suse/11.3 |
2 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
3 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
4 | repo-update | openSUSE-11.3-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.3

Ditto to kmix

Created new user. Panel icon appears and reports “Networking information not available”. When clicked box appears with faded “Network Management disabled”

Started from console…

guest@linux-4cfs:~> knetworkmanager
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)

This is very strange. When I went into Yast it told me that ifup was running. I have never run ifup to my knowledge. When I tried to activate Network Manager, it told me there was no network running. I am on vacation with my netbook with an installation from the 11.3 live CD. Please don’t waste your time on this. As long as I can connect with ifup I will wait till I get home and do a clean install. I hate this notebook anyway and have had repeated problems since I switched from 10.3 to 11.3.

Thanks for all the help.

No worries. Enjoy your vacation.

I just tried to reboot. It wouldn’t. I booted from a USB stick and ran fsck. Tons of errors. I think the SSD is trashed. This is particularly annoying because I have put no more than six weeks of use on this netbook since I bought it for travel only. This is the second ASUS product I have had problems with. The first one, a desktop, had the motherboard replaced under warranty (what a joke!) four times before I threw it out.

Sure sucks that!

Send it back with some rotten fish :wink: