knetworkmanager or ifup

Hi everybody,
My laptop is ACER 4736, OS: openSUSE 11.2, KDE 4.5. I have 2 problem, can you help me?

  1. knetworkmanager: when I start OS, knetworkmanager start at boot, but it actives wireless at the end of booting (even after RSS feed, check gmail). So RSS feed always notify that: “Connection failed”. After activating wireless, I can connection. Can I set up knetworkmanager to active wireless at the first?
  2. ifup: I try to change to connection with ifup(using DHCP), then I receive IP address, but I can’t connect internet.

Thanks for reading

You could think of replacing Networkmanager-kde4 by the plasmoid-networkmanagement. On my laptop, it connects during startup of KDE to trusted networks (i.e. configured to connect automatically), so Kopeta (IM) and the weather widget have already connected when the desktop “arrives”.

Another solution can be found by searching the forums for: BIND_NOW. You’ll find a hack that makes Networkmanager-kde4 start earlier. Mind, this “solution” has to be reapplied on each update of KDE.

For computer room systems (often called servers of all kind) and destop systems, which share the fact that they always connect to the same network, the standard way of starting the network at reaching runlevel 3 or 5 is used. This is also called "traditional with ifup. This is regardles of the fact that the connection is cabled or wireless.

For laptop systems and other systems that are carried around it is often the user that decides where to connect to beacuse several networks may be offered at a time. That means that the network can only be started after a user is loged in (in the GUI). Thus the network is NOT started at boot (into runlevel 3 or 5) but instead the network manager service is started. When a userlogs in he then can use the networlkwmanager client of his choice (often offered by the desktop of his choice) to connect, disconnect, reconnenct elsewhere, etc. Again, this has noithing to do with cabled or wireless, but laptops very often use wireless. (Mark that conrtary to what you think above, the wireless is NOT started at end of boot, but after login of a user. You may have got this misunderstandung by the fact that you use automatic login and thus the difference between boot and login is not very clear to you).

When you can not connect to the internet using an “traditional ifup” configuration, you have a problem that most probably can be solved when you ask for help and provide information on what you configured how (using Yast?). And better do add output of things like */sbin/ifconfig -a * and *netstat -rn *
(I assume that you have connection to your LAN (router) when you state that you can not connect to the internet).

If you can’t get to the internet when using “trad method ifup” in Yast, just add the IP addresses of your DNS Name Servers plus the Ip address of the gateway into the mix. Here’s how with pictures: Configure a network card in Suse/openSUSE 11.x for Internet Access & wifi.. Go to the section “Adding Name Servers and a Gateway to your IP configuration”

Many thanks to Knurpht, hcvv and swerdna :slight_smile:
I use ifup by Yast so I do follow swerdna’s recommended and add DNS in network setting. It’s done :). Now I can start with ifup normally.
About knetworkmanager, I’ll try plasmoid-networkmanagement as Knurpht’s recommended.

Kopeta (IM) and the weather widget have already connected when the desktop “arrives”

It’s exactly what I want :slight_smile:

Thank you again Knurpht, hcvv and swerdna :slight_smile:

Another solution can be found by searching the forums for: BIND_NOW. You’ll find a hack that makes Networkmanager-kde4 start earlier.

Sorry, I search with keyword “Bind now” and result’s very much. I don’t know what topic to read :frowning: Can you show me?