knetworkmanager on normal user


i updated opensuse 11.0 to opensuse 11.1 beta4 and now knetworkmanager in normal user doesnt connect to any network.

it detects one , but doesnt connect. ( doesnt seem to do anything )

launching knetworkmanager as root properly coonects and works.

it was all working nicelly in opensuse 11.0

maybe some permissions got changed ? any help ?


go into Yast > Network Devices & check your setup. Network manager needs to be ticked. Look at the other tabs for correctness.

sure , already done that.

networkmanager is working fine. if i use knetworkmanager on root , it discovers and connects to wireless networking nicelly.

user also discovers wireless networks, but it does nothing when i click on them. it doesnt even try to connect ( at least the systray doesnt change to the trying to connect animation )

both networkmanager and traditional mode are working fine with root.

my guess is some kinda of weird permissions , because everything seems properly configured

I also had this problem, and kmix would not start at all (no sound). After I altered my group policy for my user in YaST (added myself to audio and network, which makes sense in a way, but pointless that I had to do that myself) After that knetwork would still not work, but I was connected to the internet if I tried it though YaST, and I had sound. I then upgraded to KDE 4.1.72 (KDE 4.2 development) and it now works, my theory is the network manager backend that nobody is talking about. It was pulled from 4.2 and now doesn’t compile properly, but is still listed on the roadmap. And although they have blog about it for Opensuse 11.1, no work seems to be showing for it. But again thats just a guess.

Knetworkmanager is being migrated from KDE3 to KDE4, which is a significant update, but it is expected to be in 11.1 at release. Unfortunately, there will be hiccups along the way.

FWIW, knetworkmanager is maintained by an openSUSE developer, so that’s all the more incentive to make sure it works… :wink: