Knetworkmanager not working with pcmcia 3g modem

I have installed 11.1 from live cd and everything seems to be working except that I cannot access the internet with a PCMCIA 3g modem from vodafone. On version 11.0 the card was detected automatically and worked without any problems.

Have you tried connecting with either wvdial or kinternet? Both programs have to be installed from the set-up DVD or from the repos.

Network Manager seems to be kinda messed up in this release, according to the posts I have been seeing.

BTW, why do people use live CD’s for everyday use? I thought these were just for evaluation purposes. After all, it seems a little unrealistic to expect everything to work perfectly in such an abbreviated version of the OS.

I have tried kinternet without luck with the pcmcia card modem.

Kinternet works fine with the pppoe Internet connection i have at work.

firstly to answer your last question with regard to the live cd, unfortunately in South Africa most of us only have access to Internet speeds around 350kbps, this makes downloading the dvd very difficult, (even the live cd of 650megs takes around 4 hours)

Ok if I boot up with the live cd of v11.0 knetworkmanager picks up the card modem as ttyUSB0 and allows me to connect without a problem (Knetworkmanager running with v0.7r815970-4.1). If I boot up with v11.1 (both the installed and updated version on my laptop or the live cd ) knetworkmanager recognises the modem as ttyUSB0 but simply will not connect. The version of Knetworkmanager with v11.1 is a newer version (I will have to reboot to get the version number).

Is it possible to roll back to the older version of knetworkmanager if so how?