Knetworkmanager not start on login

I am running 11.3 on a desktop and knetworkmanager used to startup upon login.

However recently, knetworkmanager do NOT startup upon login.
I have to manually start the application from the menu.

YaST / Network Devices / Network Settings / Global Options Tab is all the while set to “User Controlled With NetworkManager”

I’ve even updated to KDE4.5 but the problem still persists.

Any idea what can be done to get knetworkmanager to startup upon login?

  • michalng wrote, On 09/13/2010 04:26 PM:
    Configure Desktop
    Startup and Shutdown
    Session Management

Make sure that “Restore previous session” is checked and KNetworkmanager isn’t in the list of excluded apps.


Thanks for the info but KNetworkmanager is already not in the list of excluded apps

Are you wireless or wired to the network?

Wireless connection.

  • michalng

as a workaround, try and add it to
Configure Desktop
Startup and Shutdown


Yup, seems to be the only way.

Want a hack (has to be reapplied after KDE update) ?

su -c 'cp /usr/bin/startkde ~/Desktop (enter rootpassword)
kdesu kwrite /usr/bin/startkde

Now kwrite opens the “startkde” file.

LD_BIND_NOW=true /usr/lib64/kde4/libexec/start_kdeinit_wrapper +kcminit_startup


LD_BIND_NOW=true /usr/lib64/kde4/libexec/start_kdeinit_wrapper +kcminit_startup +knetworkmanager

Logout, login and the networkmanager will be started and connected before the desktop appears :slight_smile:


Thanks for sharing but it comes a little too late.

Tried adding knetworkmanager into Autostartup and it didn’t work !!

Got tired and just deleted the home folder and restarted from scratch. Knetworkmanger now behaves properly.

hello all…

after having issues getting knetworkmanager to simply run, i’ve finally gotten it to run.
run simply, that is.
it still will not run automatically on startup.
…i’ve added knm to autostart, but there is no improvement.
…i tried the code posted by knurpht, but nothing happens after the first line.
.i would try the “delete home folder and restart from scratch” method, which seems to work, but i dont really know what michalng means by deleting the home folder and restarting.

i would greatly appreciate any more help in getting knm to run properly–that is, automatically at startup.


when I say “delete home folder and restart from scratch”, what I actually do is

  • start dolphin
  • make sure dolphin show all files and directory (including hidden files) ->View->Show hidden files
  • select everything (all files and folders, not including your personal files)
  • delete them
  • restart

Hope that’s clear enough.

thanks for the explanation.

but, that seems rather invasive just to get knm to autostart.
how does deleting the all of that make knm autostart?
…i understand it worked for you, however, i need to know a little more about this process and what is at risk before i would to this.

Basically, my openSUSE desktop installation had 5 user account and only 2 of the my account have problems.

So the installed system should be okay.
The problem probably lies in the user’s (kde?) settings that no one seems to understand which specific setting caused this strange behaviour.

Short of deleting the user account and restart a new one, deleting the entire home folder basically resets the user setting to brand new.

The only risk is losing all the user setting.
If you have spent too much time customising your user profile to perfection and afraid that you may forget how the setting looks/feel.
Then just add a new user and play with it until you are comfortable before deleting this old “problematic” account.

thanks for the explanation.
…until this morning, i couldnt get knm to even run. so, the autostart issue is relatively minor, compared to it not running at all.
i know that common issues with opensuse are usually handled quickly. i’ve actually been kinda surprised this issue has been lingering for as long as it has been.

…i definitely understand your undercut method, now. and also have a little better understanding to possible causes to the issue itself.
but, it has taken me quite some time to get my system the way i like it. i do not want to start from scratch again.
…thanks for your time and effort.

hello, good people.

…i was just checking in, wondering if anyone has managed to find a fix for this issue.
has there been any progress on getting Knetworkmanager to start automatically, that is, without having to torch and rebuild all of my current settings and specs.
as of right now, everytime i boot and reboot, i have to “run program” in order to access my networking.

it’d be great of any of you have a solution.
…but if not, could someone or -ones please respond to actually let me know that the issue still remains.
i really dont like it when forums hang and hang, with any answers at all.

thanks, again, people.
you’re the best!

Here’s a true solution:

Start the software installer. Search for ‘networkmanagment’, it return with a package for the plasmoid-networkmanagement. Select that for install. It’ll tell you it’s going to uninstall Networkmanager-kde4, that’s OK.
After it’s done, logout, login. If you don’t see the icon, right click in the system tray, go into the settings of the systray. Take a look around and you will see an option ‘Networkmanagement’, check it. Now you’ll have not only the icon, but a very nice and quick interface as well.

Here’s a true solution #2 :smiley:

Tried it and so far so good … install wicd here

this works well. in fact, its better than it was pre-problem.

thank you so very much!!
…once again, the opensuse community has proven itself to be the best of the linux world!

To see the new plasmoid widget I needed to right-click my task bar, Unlock Widgets, select Panel Options / Add Widgets, filter the widgets with “network” and choose “Network Management”.
Thanks for the pointer to this new Widget!

I had the same problem on kubuntu
I’ve edited


looked for the [general] section and changed




Once again I haven’t used a Suse OS for at least 5 years !!