Knetworkmanager Icon


I have problems with the KNetworkmanager Icon in the Kicker on one notebook (Opensuse 11.1, KDE 4.2.2, standard KNetworkmanager=KDE3 knetworkmanager).
The Icon is not visible, it is transparent. The problem ist you can’t see if the networkmanager is connecting (gearweel) or not (of course in the end you see if you are in the internet or not;-)). Due to many connection problems it is necessary to have a look on the icon and see what is happening.
How can I get this icon working?
Also tried to delete plasmarc and plasma-appletsrc. This didn’t help.
Did someone tried the KDE4 Networkmanager plasmoid?



What repos are you using:

zypper lr

Hello caf4926,

thanks for the quick answer!

following repositories are installed:

| Alias | Name | Aktiviert | Aktualisieren

1 | KDE:/42/openSUSE_11.1/ | KDE:/42/openSUSE_11.1/ | Ja | Ja
2 | KDE:/KDE4:/Community/openSUSE_11.1_KDE_42/ | KDE:/KDE4:/Community/openSUSE_11.1_KDE_42/ | Ja | Ja
3 | KDE:/Qt/openSUSE_11.1/ | KDE:/Qt/openSUSE_11.1/ | Ja | Ja
4 | Libdvdcss repository | Libdvdcss repository | Ja | Ja
5 | Packman Repository | Packman Repository | Ja | Ja
6 | driver:wireless | driver:wireless | Ja | Ja
7 | home:j-engel | home:j-engel | Ja | Ja
8 | multimedia:audio:KMP | multimedia:audio:KMP | Ja | Ja
9 | openSUSE 11.1-0 | openSUSE 11.1-0 | Nein | Nein
10 | openSUSE-11.1-Oss | openSUSE-11.1-Oss | Ja | Ja
11 | repo | openSUSE BuildService - Wine CVS-Pakete | Ja | Ja
12 | repo-debug | openSUSE-11.1-Debug | Nein | Ja
13 | repo-non-oss | openSUSE-11.1-Non-Oss | Ja | Ja
14 | repo-oss | openSUSE-11.1-Oss | Ja | Ja
15 | repo-source | openSUSE-11.1-Source | Nein | Ja
16 | repo-update | openSUSE-11.1-Update | Ja | Ja
17 | repo_1 | openSUSE BuildService - GNOME:Community | Ja | Ja
18 | repo_2 | openSUSE BuildService - KDE:Community | Ja | Ja
19 | repo_3 | openSUSE BuildService - Treiber für Web-Cams | Ja | Ja
20 | repo_4 | openSUSE BuildService - Spiele | Ja | Ja
21 | repo_5 | Packman Repository | Ja | Ja



LOL, it’s quite big. :smiley:
I’m using the KDE4 Networkmanager plasmoid, you should try it.

I see a couple of things:
Both Videolan (dvdcss) and Packman are enabled; this raises multimedia trouble.
Both jengelh and multimedia:KMP; isn’t Jan providing alsa kernel modules as well?

Re. the networkmanager: use the plasmoid, it’s realy good.


now, I tried also the new KDE4.2.3, no result.
Regarding VLC: I did not enabled the VLC repository, only the libdvdcss repository (contains only libdvdcss). VLC was installed from packman.
The Jengelh repositry was needed for the ALSA drivers.

I will try out the KDE4 Plasmoid. What should I install? Should I also deinstall the KDE3 Knetworkmanager?

Greetings and thanks


You don’t need to uninstall the KDE3 Network manager.
The KDE4 plasmoid is called: NetworkManager-kde4, install with:

sudo zypper in NetworkManager-kde4

Good luck.

I think the reason for the confusion is because there are two different things here.

There is a kde networkmanager plasmoid AND a kde networkmanager icon you can install to manager you network connections that goes in your task bar. I use both at times but the kde networkmanager icon has more functonality than the plasmoid.

I have had both working in every version of kde 4 so far.

Which one do you really want?


Is this a program problem or a connection problem?

Looks like a program problem since the OP said the icon is invisible but still connects.

As for the KDE3 network manager vs. the KDE4 network manager. Personally, I like the KDE3 one better, mostly because then I don’t have to use Kwallet. But it’s not so much a pain that it disrupts anything. You just have to enter your password for Kwallet anytime you connect to a network. I do like the visual representation that the KDE4 network manager brings when scanning for networks though.

If you need to switch to KDE4 network manager it still has all the functionality, just one more step to get her up and running.

Take Care,



thanks for your answers :)!
I installed the KDE4 Networkmanager on my notebook. It works fine and looks great.
After rebooting, both Networkmanagers (KDE3 and KDE4) will be loaded. I deinstalled the KDE3 Networkmanager and now it’s fine.

On monday I will change the Networkmanagers also on the other notebook (the notebook with the invisible icon is the notebook of a colleague).