KNetworkmanager doesnt work


im new in this Community and from Germany, so my Englisch could be may better ;).
My Problem:
I want to connect my OpenSuse 11.3 Distribution with the Internet via WLAN.
But i can’t open the KNetworkManager. It doesnt respond to my clicks.
If I click on the KNetworkManager “Button” it doesen’t react.
Result : I can’t modify my WLAN-Connection.

I hope you can understand my problem and help me :slight_smile:
Your Wuzabi.

You need to open YaST, enter the root user password, go to Network Devices / Network Settings. On the Global Options Tab, select the Bullet for User Controlled with NetworkManager. If you can not get NetworkManager to load, that is often due to having the default of using Traditional Method using “ifup”, a sort of manual mode setting for networking. You also need to run Kwallet, KDE menu / System / Desktop Applet / KWalletManager, which is used for your network security password storage. Then, you should be able to restart your desktop and see NetworkManager load.

You would right click on it and select Manage Connections. Then, you must enter all of the information about your network connection. All of this working does assume that your Wireless adapter is recognized by openSUSE. I have a bash script that can be used to get info from your computer you can post here for us to see. Do NOT post any info about your network name or password, we do not need to know that.

netinfo - Read Network & PC Information into a Local Text File

Message #11 had the most recent version of netinfo listed as I recall.

Thank You,

Thank You,

Thank you very much, i will try it now ;).

Hello again :slight_smile:
It works, thank you very much!
But if i open the KNetworkManager , i can’t choose the WLAN path/button. All others would work (DSL, Modem …)
How can i change this ? Or why does it not work ?
Thank you again

Greetings from Germany

It works, thank you very much!
But if i open the KNetworkManager , i can’t choose the WLAN path/button. All others would work (DSL, Modem …)
How can i change this ? Or why does it not work ?
Thank you again

Greetings from Germany
So, what is working and what is not working? That is, do you have a hard wired connection that is working and Wireless connection that is not working? When you right click on NetworkManager, you can pick Manage Connections and is says what the Active connection is. If you want to use Wireless, you must pick Manage Connections, go to the Wireless Tab and create a New Connection. IF your hardware is working, you should be able to scan for local connections by name. IF the hardware does not work, you will see nothing. If there is NO network connection that is working, NetworkManager will not even load.

Thank You,

Thank you again for your answer.
The problem is, that i can’t choose the WLAN Tab. I can’t click on it. All the other Tabs are working (like DSL, Modem …).
But my Fritz! Wlan is installed correctly.
Once again, my Problem is, that all Tabs are working but not the WLAN.
What could be a reason for this, and how can i change this ?

Thank you and Greetings from Germany

So you need to tell us about your computer hardware. Model, brand, if you know the type of Wireless hardware you have, that would be helpful. To get wireless to work is a three part process. The hardware must be detected and the correct driver has to load. New wireless hardware drivers often lag behind the Linux driver support. The older the unit, the more likely said support will be present. The driver may exist, but does not load automatically because you must download it from the Manufacturer.

For instance, my Dell Laptop uses Brodcom Wireless. The driver exists, but is not included in the Linux kernel. So I must download and install it manually. Next, the NetworkManager must be setup to load automatically. Anytime it does load, but no wireless is present just means you have a hardwired network connection that NetworkManager does properly detect. Finally, after the wireless hardware driver is loaded, NetworkManager is configured to auto load, you must configure your wireless connection. The last part can only occur after the hardware driver has been loaded.

I would still implore you to run the netinfo script file I mentioned before and post the information from that script file here in a message.

Thank You,

You may also download and invoke this script (German instructions) or this script (English instructions). Your system will be checked for common network configuration problems and otherwise the created output will provide valuable information about your network config. If you run your box with a German locale you will get all messages in German - other locales will get English messages.

For any KDE user who “knows” that their wireless hardware is working, there is a fix for KNetworkManager not working properly which I have found here online by one of our super users in this forum. Basically, if you can get your wireless to work using the “Traditional method with ifup”, then you need to KBlast your old network and KWallet settings away and start over. Open up a terminal session and enter the following terminal commands.

sudo /etc/init.d/network stop

rm -rf ~/.kde4/share/config/networkmanagementrc

rm -rf ~/.kde4/share/apps/networkmanagement

rm -rf ~/.kde4/share/config/kwalletrc

rm -rf ~/.kde4/share/apps/kwallet

I then suggest you log out of KDE and reboot your computer. 

Upon return to KDE, please do or check the following items:

Load Required Programs using: YaST for KNetworkManager & KDE menu for Kwallet

You Must run: YaST / Network Devices / Network Settings / Global Options Tab
and select the bullet option for: User Controlled with NetworkManager

To use Kwallet open: KDE Menu / System / Desktop Applet / KwalletManager

When you first run KWallet, you must enter some basic setup information for it to work. Once KNetworkManager is loaded in your icon try, right click on “Connect to Other Network”. Select the name of your wireless network, select the right Security type and enter the security Password and you will be in.

If you can not connect to your wireless router using “Traditional method with ifup”, then it is very likely none of these instructions here will help in your case.

Thank You,