KNetworkManager does not autostart anymore...

Since a few days KNetworkManager does not show up in the system tray anymore - nor is it running.

It used to start automatically after logon, after it was started manually once.

Now, after switching the “Network Setup Method” (with YaST>Network Settings) from “User controlled with NetworkManger” to “Traditional Method with ifup” and back a number of times, the KNetworkManager does not want to restart automatically any more…

Any idea what my cause this problem?

BTW: I am on openSuse 11.1 with kernel

Looks like my problem is a singular case, so let me rephrase my question:

How does KNetworkManager - and all the other system tray programs - start automatically after logon to KDE?

Adding KNetworkManager to the autostart list in the “Personal Settings” does the job, but this seems not to be the official/regular way to accomplish such autostarts…

Any hints are appreciated very much.


You could check that ~/.kde/share/config/knetworkmanagerrc has Autostart=yes.



Autostart is set to “no”…
Setting it back to “yes” did the trick!
Thank you very much!



You’re welcome.
Glad you got it working.