KNetworkManager detects WEP instead of WPA?

Hi there,
I have a strange error here.
I am using a dell laptop with the following WLAN adapter:
Dell TrueMobile 1150 Series PC Card

It shows all the available WLAN access points but the type is not correct.
If I try to connect to my own WLAN (Router is T-COM Speedport W701 V) it fails.
My WLAN is configured with WPA and TKIP but the KNetworkManager leaves only the following options:
WEP Passphrase
WEP 40/104 Bit-Hex
WEP 40/104 Bit-ASCII

OK, I thought that it could be better to configure it manually by defining the ESSID and WPA with TKIP …
But then it fails again and shows again the window saying that the connection could not be established. With the three WEP options.
Now what?

I tried to connect with another windows laptop - there it worked.

Why does the network manager detect the wrong type?

How can it be repaired?

Please help!


I tried also with another suse laptop - it detects the WPA correctly and connects without any problem.

So it might be a problem of the driver?
What do you think?

Any ideas how this can be fixed?


i think it must be a problem with knetworkmanager, i had a problem where it detected WPA instead of WEP. try just keeping it at WEP and put in the pass key. failing that try downloading and compiling something like compat drivers. although don’t until someone else with better wireless knowledge come on. try using another program which is good, i used wifi-radar for suse 10.3.


Fact is that the supplied driver like the orinoco_cs does not support WPA, just WEP.
I had the same troubles on my Dell C640 which has a TrueMobile 1150 with an Agere Hermes1 chip like most of them, but there are a lot of card/chip combinations out there. It’s chaos.
Im using Suse11.0 and have kernel by the.

There have been tons of threads about this and thanks to the guys at Ubuntu there is a solution.
What you need is the wlags49_h1_cs driver. This one results from improvements on the original Agere driver which can’t even be gotten anymore since Agere has been taken over by LSI and the driver page is off-line.

Follow this link : Edgy Eft WPA and Wireless default-install error? - Page 11 - Ubuntu Forums
There are 12 pages but go to page 8 where user carac has attached wlags49-h1-cs.tar.bz2. Also, read through from there for interesting info on compilation errors or a solution for hibernation.

You’ll have to compile that after changing the CFLAGS variable to EXTRA_CFLAGS in the Makefile and comment out SET_MODULE_OWNER(dev); in wl_cs.c.

Of course, install the kernel sources, kernel headers and kernel-syms that correspond to your kernel. Easy with yast.

Then make and make install in the folder where you unpacked your download as root.
Then blacklist orinoco_cs in /etc/modprobe.d/blacklist.
Detach the orinoco_cs module from the kernel :

pccardctl ls

pccardctl eject 2 (the no of the socket you saw with the prev cmd)

modprobe -r orinoco_cs

modprobe wlags49_h1_cs

pccardctl insert 2

Have a tail -f /var/log/messages open to see what’s happening.

Now configure your network setup with yast.

This worked for me.


Well, so far, I’ve downloaded, and untarred the file. I’ve attempted to ‘make’, but I get this:

make[1]: *** No rule to make target `modules’. Stop.

Any idea why make quits? :frowning:

mad eng wrote:
> Well, so far, I’ve downloaded, and untarred the file. I’ve attempted to
> ‘make’, but I get this:
> make[1]: *** No rule to make target `modules’. Stop.
> Any idea why make quits? :frowning:

You do not have the necessary kernel parts installed.

OK. I’ve installed the kernel headers via yast before attempting the compile; as well as verifying gcc is installed.

Is there something else?

Ahh… I didn’t install the kernel-source. Installed that; and now can run ‘make’.

Basic stuff for comppiling :- Kernel sources, gcc/gcc++ & make.The readme instructions contained with the tarball should explain


Thanks to all for the help! WPA is working! rotfl!

kudos to gzelk and our friends at ubuntu for coming up with this work-around!

And what workaround is that ? Please post it so that others may benefit