knetworkmanager 11.3?

I’m trying to figure out how to start up knetworkmanager (I like the tray icon - it gives handy information) - but can’t figure out how to switch to it from ifup. I’ve been googleing for a while now and thought I’d post a question. It used to always be default, but now it’s missing. I use it and it seemed to work well with my Verizon USB720 cell modem under opensuse 11.1.

TIA,
PattiMichelle

To start it, hit ALT+F2 to bring up krunner, then type KNetworkManager and hit <enter> to start it. To set it as default, start YaST then click on Network Settings, then choose the option “User Controlled with Network Manager”. That should do it! Let me know if it works for you!

switching from ifup to network manager is done via yast

Network Devices > Network Settings

Yes, that worked fine - I thought ifup vs. knetworkmanager was a chilce I had to make - OIC - this just starts it, then I have to go into YaST and make the switch!

OOOOooohhhhh! I didn’t notice the tabs at the top of the initial screen in Network Settings - I needed to select the Global Options tab to see the setting I needed! THANKS!!!

I’m glad it worked out well for you!

No probs Patti

Oops - it didn’t work after all - - - - - I started knetworkmanager and it worked, then I changed the setting in YaST, but knetworkmanager stayed in “disabled” mode, ever after a reboot. I checked that Networkmaneger packages were installed in YaST… (“Network Information Not Available” and “Network Manager disabled” when left/right clicking on applet in tray)

You are using this for wireless - yes?

And if ifup works - why the switch?

Thank you for the reply…
Well, I have a Wifi and also a USB720, which networkmanager (under 11.1) showed as TTYUSB0/1 - I see it’s there in /dev - but knetworkmanager shows nothing (it used to show wired + wifi + USB720 under 11.1 - and I didn’t have to mess around with any settings so something must have changed). And under 11.1 it would automatically switch between various connections as appropriate (wired/wifi - but USB720 use was a little more tricky).

11.1
would be kde3 ?
I use network manager on 2 laptops and I never do any settings in there for wired connections, they just connect.
I no knowledge of your usb cell modem - sorry

No, I was using KDE4 in 11.1, though always used KDE3 before that. Problem is that knetworkmanager doesn’t ever seem to “come alive” - even though I tell in YaST to use knetworkmanager (and when I do that, all wifi/wired network availability goes away).

Is that with wired removed and wireless attached?
Strange though, mine just switches from one connection to the other as and when I remove/connect wired.
Try removing any old config files from .kde4 and even .kde
I’m fairly certain that 11.1’s kde4 used kde3 network manager

I’ve seen this issue lots of times. Though i can’t remember seeing it before 11.2 (it should be introduced around that release i guess)

Anyway… I use the NM-applet that comes with the NetworkManager-gnome package instead of KNetworkManager.
Just the switch in frontend will solve your problems.

I’m experiencing the same problem with a fresh install of 11.3 on our laptop (using an old /home directory). I suspect something in the old /home has brought this about , and thus far the only way to get my wireless to connect is via the tradional method. I have not tried the NM-applet that comes with the NetworkManager-gnome package instead of KNetworkManager.

I tested a different user on KDE and that user does NOT have the problem. Thus my problem is user specific … ie something left over from a prevous /home/oldcpu. I’m tempted to delete that oldcpu user and try again.

Sounds like you need to run NetworkManager and do the initial setup.

I don’t think so (ie running NetworkManager gives NO options for an initial setup).

Knetworkmanager works in 2 users account which previous never used wireless in older openSUSE versions. In the user account where wireless was used before (with previous openSUSE versions) knetworkmanager does NOT work. Hovering the mouse over the knetworkmanager small icon in the lower right corner gives the dialog: “Networking Information Not Available”. Clicking on the icon gives a greyed out “Network Mangement Disabled” which is not selectable. Networkmanager is already running, so typing “NetworkManager” to run it does not help. If one ‘kills’ NetworkManager and runs it again from a konsole, it starts with no options. Running “man NetworkManager” suggests there are no configuration setups run from a command.

Its far from intutitve, and hence not functional. Its likely just easier to dump this user and go with a new user.

That seems to answer it IMO

That sounds like what I saw with the NM applet, except this was an entirely fresh install. Methinks someone changed something deep in KNM… Wish I knew how to get it going like in 11.1… <wah!>