knetwork manager: enable/disable wireless to connect

Hi all,
I have a minor problem with Knetwork-manager. When I boot up, it won’t connect to my wireless router automatically. I have to right-click the taskbar icon, disable wireless, then enable wireless, then it connects fine.
It remembers the password fine and once it’s connected, it’s flawless. It’s just the minor issue of having to effectively ‘switch the internet on’ rather than it just being connected when I turn on my laptop.
I’m using Opensuse 11.2, KDE 4.3.1 (didn’t have this issue with 11.1). I’ve tried the latest Kubuntu (9.10) and knetwork-manager worked flawlessly but I didn’t like the rest of the OS so I came back to Opensuse :wink:
If I restart, suspend or hibernate it usually connects okay, it just seems to be when I boot from ‘cold’.

I’ve tried nm-applet but same problem. I also tried wicd but it didn’t really like my system. I’ve changed my wireless router recently as well with no change, so I don’t think it’s that.

As I say it’s a minor problem, it’s not really an issue for me to turn it on each time but it would be nice to clear it up.

I’ve googled and searched since 11.2 was released but haven’t found any answers and my linux skills are still a bit lacking.

Any help or guidance in any way would be most appreciated.



I’m having the exact same problem after installation of OpenSuse 11.4 KDE. Does anyone know how to fix this?


Check to make sure that you’ve enabled “Connect Automatically” by
Click on the network manager icon
Click “Manage Connections”
Click the Wireless tab, find the entry for your connection and click “Edit”
Verify the “Connect Automatically” radio button is checked.

What you’re seeing likely is that network manager sees your network as one it has connected to before but hasn’t received the auto connect command to proceed.

If you’re seeing what I’ve seen, it’s a transient problem only seen after first install. After seeing it once, I haven’t seen it again…
If you see it repeatedly, then I recommend posting starting a new thread (It’s not typically good etiquette to hijack a thread if it’s not exactly the same issue).

HTH guys,