KNetwork manager does not set resolv.conf

Dear all,
I was using the fixed classic way to connect my wireless to my home network (there is an option in Yast, this is the ifup I think).

Now I asked from Yast to allow me to use network manager to handle my wireless connections (as I am on vacations and my home connection is not available). I have installed the right plasma widget to control the wireless connection in the latest opensuse (12.1).

My problem is that I can connect to a new access point, authenticate correctly, get a ip address from the dhcp (running at the wireless access point) and have my route to be set automatically. The only problem is that it fails to edit /etc/resolv.conf and write there the dns that it should use.

Could you please help me understand what I can try to do to fix that part? Why my resolv.conf does not change automatically. For your interest this access point can be accessed from windows machines and everything works fine. (one click - give password- ready)

I would like to thank you in advancve for your support

B.R
Alex

Why not check for a certain Network setting to see if this can be fixed. You did not mention your desktop but …

In KDE Do: Alt-F2 and enter: kdesu kwrite /etc/sysconfig/network/config

OR

In Gnome Do: Alt-F2 and enter: gnomesu gedit /etc/sysconfig/network/config

Search for NETCONFIG_DNS_FORWARDER and make sure or set it to say:

NETCONFIG_DNS_FORWARDER="resolver"

If different, change and save and restart openSUSE. Report back what you found and if it helped in any way.

Thank You,

If you have changed resolv.conf, or if NM thinks you have, it will not replace
it. Try deleting it and restarting the network.

Good Morning and thanks for your reply

It seems this value to be set to the right one.
Once I connected to the access point I issued the

mylinux:/home/aos # dhcpcd wlan0
err, wlan0: suspect value in option DHCP_DNSDOMAIN - discarded

which returned an error, although the /etc/resolv.conf file was succesfully edited, and the internet access works fine.
What should I try now?
B.R
Alex

On 01/02/2012 07:16 AM, alaios wrote:
>
> What should I try now?

i am not a networking guru, so i defer to anything and everything
suggested by the others here…

however, i have (i think) solved your problem (and mine) by manually
editing the resolv.conf file so that it always points to a set of
domain nameservers known to be good (well updated, fast, dependable,
geographically diverse) and correctly set for IPv6…

by doing so i avoid my ISP’s broken (in regards to IPv6) nameservers and
those of any wireless network i might hook in to while moving around…

i find it very nice that Network Manager will not even try to ‘update’
my resolv.conf once i have manually edited it to NOT use every new name
server it might be offered in any far flung coffee shop, hotel, internet
cafe, street corner…

a how-to edit in the free Google name servers is here:
http://tinyurl.com/c9a3utb

but, ymmv and read my sig’s caveat and let the real gurus here vote…


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
openSUSE®, the “German Engineered Automobiles” of operating systems!